Questions on using the hardware, FPGA design, building your own, custom interfaces, etc.
#1823 by Daniel
Tue Feb 13, 2018 2:54 am

I get the following warning when I try to connect chipwhisperer. Could anybody tell me what caused the issue and how to solve it?

Could not execute method run in script class UserScript: 'IOError:[Errno FPGA Done pin failed to go high, bad bitstream?] <zipfile.ZipExtFile object at 0xab21932c>'

Traceback (most recent call last):
File "/home/cwuser/chipwhisperer/software/chipwhisperer/common/api/", line 394, in runScriptClass
return eval('m.%s()' % funcName)
File "<string>", line 1, in <module>
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scripts/", line 47, in run
File "/home/cwuser/chipwhisperer/software/chipwhisperer/common/api/", line 277, in connect
return self.connectScope() and self.connectTarget()
File "/home/cwuser/chipwhisperer/software/chipwhisperer/common/api/", line 239, in connectScope
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/", line 60, in con
if self._con():
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/", line 99, in _con
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/openadc_interface/", line 108, in con
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/cwhardware/", line 240, in loadRequired
self.loader.loadRequired(self.loadFPGA, forceFirmware)
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/cwhardware/", line 186, in loadRequired
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/cwhardware/", line 267, in loadFPGA
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/cwhardware/", line 193, in loadFPGA
File "/home/cwuser/chipwhisperer/software/chipwhisperer/hardware/naeusb/", line 84, in FPGAProgram
raise IOError("FPGA Done pin failed to go high, bad bitstream?", bitstream)
Warning: Could not execute method run in script class UserScript: 'IOError:[Errno FPGA Done pin failed to go high, bad bitstream?] <zipfile.ZipExtFile object at 0xab21932c>'
#1824 by fheubach
Tue Feb 13, 2018 8:07 am
Hi Daniel,
Could you please send me the chip whisperer lite serial number and the firmware version you are using?
This can be found in the "debug logging" tab in the bottom subwindow in the capture software, when the connect to scope button is pressed.
Kind Regards,
#1825 by Daniel
Tue Feb 13, 2018 10:15 am
Hi Franz,

INFO - Found ChipWhisperer-Lite, Serial Number = 4420312046304a383030312036313032
INFO - SAM3U Firmware version = 0.11 b0
INFO - Detected ChipWhisperer with USB ID ace2 - switching firmware loader
ERROR - Traceback (most recent call last):
#1827 by Daniel
Wed Feb 14, 2018 5:00 am
HazratDeewana wrote:Hi
I am new here and I am a tourist guider at Kapasan wale baba, Chittoor Dargah.
Best regards
Hazrat Deewana

Good for you buddy, if I take a tour my problem will be solved?
#1828 by coflynn
Wed Feb 14, 2018 8:32 am

Are you running inside a VM? I've seen this issue before with VM devices sometimes and never fully solved it I think.

Q#1: Are you using the latest SW?

The one thing to try is force setting a specific FPGA bitstream. This can be done under "Tools --> CW Firmware Preferences".

Q#2: What is that currently set at? It should be" Builtin". You can try switching to "External (.zip)" which should find itself pointed at "chipwhisperer\hardware\capture\chipwhisperer-lite\".


#1829 by Daniel
Thu Feb 15, 2018 4:57 am

Yes I was running inside a VM, I tried it from a chipwhisperer capture (version 3.5) installed on windows and it gave me the same warning.
It is set to builtin, but even when I try to set it manually to external the program fgpa button is inactive.
#1833 by coflynn
Wed Feb 21, 2018 2:28 pm
Hi Daniel,

Sorry on slow response - we've had that issue before and I've been trying to find the previous fixes, as I didn't well document it (some of them were committed to GIT as well so thought maybe it would already be sorted out).

Setting to manual is a little odd. You need to first set to manual/zip-file, then disconnect/reconnect. It should detect the FPGA is not programmed and send the new bitstream to the device.

Did it ever work or is this a new device? The hardware is pretty robust so unlikely to be damaged, but anythings possible so want to figure out exactly.

#1840 by Daniel
Wed Feb 28, 2018 4:09 am
Hi Colin,

I tried the suggested solution but with no luck...
Yes it was working, and at some point it just started giving me this error.
Also I had to find a pc that is not behind a proxy... The installations of chipwhisperer doesn't 'always' like to run on every pc (strange), or in the list where you should choose the scope module only "none" is available... So this is why I preferred to use the VM (working from windows).

Any idea of what might be wrong and how to solve it?

#1937 by Daniel
Thu Mar 29, 2018 6:24 am

I finally had time to take a closer look on it, the 3.3V and the ground was shorted. Under the thermal camera the atmel chip emitted some heat, but there were other differences between a working unit and this, so I opted to take off the ADC, VGA, FPGA and micro. The ADC and VGA seems to be fine, as they don't have short between VDD and GND, and from the PCB the short also disappeared which leaves the micro or the FPGA.
Any idea what could cause the issue under normal use?
I have some suggestions, in the next iteration of the PCB try to ground everything properly, including USB and the stands. I am working on ESD protected surfaces and if some charge gets grounded, it has a potential gradient, and with the longer distance it becomes greater. I can imagine that as the stands are not connected to the ground (but cooper on the PCB is close to it on multiple layers as I saw it under X-ray) 5-8KV or more (with tiny amount of current) was present and it found a way through the FR4. Or this or the board self destructs. PCB design is not black magic. Also between the traces, flood everything with cooper (except in the analog part). For start google high frequency pcb design.
#1943 by coflynn
Mon Apr 02, 2018 8:38 am

Hmm - this short would be odd in regular use! The FPGA might be more likely as it is "device facing" (i.e., if you put 5V in by accident to target device). Note there are separate power nets for the SAM3U & FPGA, so you should be able to determine which 3.3V rail. If it's a solid short I think it's possible it is something physical on the pins of the chip? Actually since the SAM3U is working it should most definitely not be that. If it was something (metal flake, solder ball, etc) that might have also cleared during the removal process.

The SAM3U gets hot normally as it has an internal LDO regulator. So it will be warm in regular use.

We didn't ground the legs on purpose, as it is too easy to introduce a ground loop if you mount the ChipWhisperer-Lite on a metal platform. The closest traces are all GND pours so I'd guess if ESD was to blame it would be from another avenue (likely target connections as they have less ESD protection, mostly relying on FPGA ESD diodes).

But if you are seeing 0-ohm short I'd see which VCC net it's on which might help you narrow down specifically.


Who is online

Users browsing this forum: Bing [Bot] and 1 guest