Discussions on Python software that powers the ChipWhisperer system
#1545 by Bonki
Sun Aug 27, 2017 5:40 am
Hi,

currently I m trying to follow the Wiki tutorial about breaking RSA
https://wiki.newae.com/Tutorial_B11_Bre ... the_Attack

Now here's my Problem:

My power trace looks like this:
Image

But it should look something like this:
Image

I am pretty sure that I followed the whole tutorial and configured everything right. Could you give me some suggestions and help, please?

btw. the automated attack script from the Wiki works just fine for me if I use the provided example traces from https://github.com/newaetech/chipwhisperer-examples but if I try to attack my captured traces it fails.

This is what my saved settings look like:
Code: Select all[Scope Settings]
[[ChipWhisperer/OpenADC]]
Connection = NewAE USB (CWLite/CW1200)
Auto-Refresh DCM Status = True
[[[FTDI (SASEBO-W/SAKURA-G)]]]
Device Serial Number =
[[ChipWhisperer/OpenADC]]
[[[NewAE USB (CWLite/CW1200)]]]
[[[[ChipWisperer-Lite USB]]]]
[[ChipWhisperer/OpenADC]]
[[[Serial Port (LX9)]]]
Selected Port =
[[ChipWhisperer/OpenADC]]
[[[OpenADC]]]
[[[[HW Information]]]]
[[[OpenADC]]]
[[[[Gain Setting]]]]
Mode = low
Setting = 45
[[[OpenADC]]]
[[[[Trigger Setup]]]]
Mode = rising edge
Timeout (secs) = 2
Offset = 0
Pre-Trigger Samples = 0
Total Samples = 24000
Downsample Factor = 1
[[[OpenADC]]]
[[[[Clock Setup]]]]
[[[[[ADC Clock]]]]]
Source = CLKGEN x1 via DCM
Phase Adjust = 0
[[[[Clock Setup]]]]
Freq Counter Src = EXTCLK Input
[[[[[CLKGEN Settings]]]]]
Input Source = system
Input Frequency = 10000000.0
Multiply = 2
Divide = 26
Desired Frequency = 7384615
[[ChipWhisperer/OpenADC]]
[[[CW Extra]]]
[[[[CW Extra Settings]]]]
[[[[[Trigger Pins]]]]]
Target IO1 (Serial TXD) = False
Target IO2 (Serial RXD) = False
Target IO3 (SmartCard Serial) = False
Target IO4 (Trigger Line) = True
Collection Mode = OR
[[[[CW Extra Settings]]]]
Trigger Module = Basic (Edge/Level)
Clock Source = Target IO-IN
Target HS IO-Out = CLKGEN
HS-Glitch Out Enable (High Power) = 0
HS-Glitch Out Enable (Low Power) = 0
[[[[[Target IOn Pins]]]]]
Target IO1 = Serial RXD
Target IO2 = Serial TXD
Target IO3 = High-Z
Target IO4 = High-Z
[[[[CW Extra Settings]]]]
[[[[[Target IOn GPIO Mode]]]]]
Target IO1: GPIO = Disabled
Target IO2: GPIO = Disabled
Target IO3: GPIO = Disabled
Target IO4: GPIO = Disabled
nRST: GPIO = Default
PDID: GPIO = Default
PDIC: GPIO = Default
[[[[CW Extra Settings]]]]
Target Power State = True
[[[CW Extra]]]
[[[[Glitch Module]]]]
Clock Source = Target IO-IN
Glitch Width (as % of period) = 10
Glitch Width (fine adjust) = 0
Glitch Offset (as % of period) = 10
Glitch Offset (fine adjust) = 0
Glitch Trigger = Manual
Single-Shot Arm = After Scope Arm
Ext Trigger Offset = 0
Repeat = 1
Output Mode = Clock XORd
#2061 by takaya
Wed Jul 11, 2018 7:22 am
Hi,
I'm facing the same problem as you.
The ADC 's sampling rate is lower or XMEGA clock is faster, I think.
I wonder anyone fixes it. (tutorial or actual parameters)
Best regards,
#2062 by takaya
Thu Jul 12, 2018 4:18 am
Hi,

Actually, I have two chip whisperers. I replaced the board, then tried again.
In that case, I got the same result as the tutorial. So I think it depends on the revision of the board.

In addition, modifing prameters in tutorial to:
> start = 2600
> rsa_ref_pattern = trace_ref[start:(start+300)]
then, the attack succeeded.

Best regards,

Who is online

Users browsing this forum: No registered users and 2 guests