Questions on using the hardware, FPGA design, building your own, custom interfaces, etc.
#1823 by Daniel
Tue Feb 13, 2018 2:54 am

I get the following warning when I try to connect chipwhisperer. Could anybody tell me what caused the issue and how to solve it?

Could not execute method run in script class UserScript: 'IOError:[Errno FPGA Done pin failed to go high, bad bitstream?] <zipfile.ZipExtFile object at 0xab21932c>'

Traceback (most recent call last):
File "/home/cwuser/chipwhisperer/software/chipwhisperer/common/api/", line 394, in runScriptClass
return eval('m.%s()' % funcName)
File "<string>", line 1, in <module>
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scripts/", line 47, in run
File "/home/cwuser/chipwhisperer/software/chipwhisperer/common/api/", line 277, in connect
return self.connectScope() and self.connectTarget()
File "/home/cwuser/chipwhisperer/software/chipwhisperer/common/api/", line 239, in connectScope
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/", line 60, in con
if self._con():
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/", line 99, in _con
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/openadc_interface/", line 108, in con
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/cwhardware/", line 240, in loadRequired
self.loader.loadRequired(self.loadFPGA, forceFirmware)
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/cwhardware/", line 186, in loadRequired
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/cwhardware/", line 267, in loadFPGA
File "/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/cwhardware/", line 193, in loadFPGA
File "/home/cwuser/chipwhisperer/software/chipwhisperer/hardware/naeusb/", line 84, in FPGAProgram
raise IOError("FPGA Done pin failed to go high, bad bitstream?", bitstream)
Warning: Could not execute method run in script class UserScript: 'IOError:[Errno FPGA Done pin failed to go high, bad bitstream?] <zipfile.ZipExtFile object at 0xab21932c>'
#1824 by fheubach
Tue Feb 13, 2018 8:07 am
Hi Daniel,
Could you please send me the chip whisperer lite serial number and the firmware version you are using?
This can be found in the "debug logging" tab in the bottom subwindow in the capture software, when the connect to scope button is pressed.
Kind Regards,
#1825 by Daniel
Tue Feb 13, 2018 10:15 am
Hi Franz,

INFO - Found ChipWhisperer-Lite, Serial Number = 4420312046304a383030312036313032
INFO - SAM3U Firmware version = 0.11 b0
INFO - Detected ChipWhisperer with USB ID ace2 - switching firmware loader
ERROR - Traceback (most recent call last):
#1827 by Daniel
Wed Feb 14, 2018 5:00 am
HazratDeewana wrote:Hi
I am new here and I am a tourist guider at Kapasan wale baba, Chittoor Dargah.
Best regards
Hazrat Deewana

Good for you buddy, if I take a tour my problem will be solved?
#1828 by coflynn
Wed Feb 14, 2018 8:32 am

Are you running inside a VM? I've seen this issue before with VM devices sometimes and never fully solved it I think.

Q#1: Are you using the latest SW?

The one thing to try is force setting a specific FPGA bitstream. This can be done under "Tools --> CW Firmware Preferences".

Q#2: What is that currently set at? It should be" Builtin". You can try switching to "External (.zip)" which should find itself pointed at "chipwhisperer\hardware\capture\chipwhisperer-lite\".


#1829 by Daniel
Thu Feb 15, 2018 4:57 am

Yes I was running inside a VM, I tried it from a chipwhisperer capture (version 3.5) installed on windows and it gave me the same warning.
It is set to builtin, but even when I try to set it manually to external the program fgpa button is inactive.

Who is online

Users browsing this forum: No registered users and 2 guests