Chipwhisperer lite fireware update

When I update the firmware, I get an error and cannot connect to the port.Who can help me?

I’ve also finally had some time to pull out my Chip Wisher Lite and start looking at doing the tutorials available via the notebooks.

As I was going through the tutorials I hit the problem of not being able to update the firmware.

dmesg output:
[93941.615885] usb 1-1: New USB device found, idVendor=2b3e, idProduct=ace2, bcdDevice= 1.00
[93941.615890] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[93941.615894] usb 1-1: Product: ChipWhisperer Lite
[93941.615897] usb 1-1: Manufacturer: NewAE Technology Inc.
[93941.615900] usb 1-1: SerialNumber: 53313120313436373230362039303030

kernel version (Ubuntu 20):
Linux 5.4.0-47-generic #51-Ubuntu SMP Fri Sep 4 19:50:52 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

based on the upgrade guide at

python output:

import chipwhisperer as cw

scope = cw.scope()
Traceback (most recent call last):
File “/home/fivedown/workspace/chipwhisperer/software/chipwhisperer/hardware/naeusb/”, line 296, in txrx
response = self.usbdev().ctrl_transfer(payload[0], payload[1], payload[2], payload[3], payload[4], timeout=self._timeout)
File “/home/fivedown/.local/lib/python3.8/site-packages/usb/”, line 1070, in ctrl_transfer
ret = self._ctx.backend.ctrl_transfer(
File “/home/fivedown/.local/lib/python3.8/site-packages/usb/backend/”, line 893, in ctrl_transfer
ret = _check(self.lib.libusb_control_transfer(
File “/home/fivedown/.local/lib/python3.8/site-packages/usb/backend/”, line 604, in _check
raise USBError(_strerror(ret), ret, _libusb_errno[ret])
usb.core.USBError: [Errno 32] Pipe error
WARNING:root:Your firmware is outdated - latest is 0.20. Suggested to update firmware, as you may experience errors

programmer = cw.SAMFWLoader(scope=scope)

When I disconnect and re-connect the device it dosen’t come back up as a serial device i.e. /dev/ttyACM0.

I’ve also tried to erase before the upload but the same issue.

Entering bootloader mode…
Please wait until the ChipWhisperer shows up as a serial port. Once it has, call
the program(COMPORT, FWPATH) to program the ChipWhisperer

        Default firmware can be found at chipwhisperer/hardware/capture/chipwhisperer-lite/sam3u_fw/SAM3U_VendorExample/Debug/SAM3U_CW1173.bin

Traceback (most recent call last):
File “”, line 1, in
File “/home/fivedown/workspace/chipwhisperer/software/chipwhisperer/capture/scopes/cwhardware/”, line 152, in enter_bootloader
AttributeError: ‘SAMFWLoader’ object has no attribute ‘usb’

Hopefully the following output helps, please let me know if there is anything else I can post to help debug.


It looks like there’s some USB issues preventing the scope from actually connecting. We recently added a new USB command and I’m guessing my code to avoid that command on older firmware isn’t completely working.

As a quick fix, you should be able to short the erase pins on the Lite, after which you can proceed with step 4 in the firmware update instructions.

@biyuanqiao you should be able to follow the same steps to update your firmware as well.


My problem is the same as yours

Thanks for your help that worked great.

I just shorted erase jumper (JP2) on the cwlite with a jumper, powered on. Removed the jumper and it came up as /dev/ttyACM0 and I was able to program the cwlite as per the doco.

Then rebooting the cwlite it came back and now I’m going through the jupyter notebooks!