Failed to upgrade firmware,CW1200

Hi.
My cw1200 device cannot start again.

I tried to upgrade CW 1200 firmware, so I followed under link : Updating Firmware — ChipWhisperer 5.6.1 documentation

During the upgrade firmware process, especially after verifying message, suddenly my cw1200 device shut down. So I disconnected the power after 3 minutes because I think if I connect power again, the device would be rebooted again. But CW1200 cannot turn on even the power is offered and PC cannot detect the CW1200 device.

So, I researched some methods to resolve this problem. I tried to directly connect pin 137(erase pin) of Atmel ATSAM3U2E to a Vcc pin. This brough it back to bootloader mode, but nothing changed. So, how can I solve this problem?
Please HELP!!!

upgrading firmware

Just to confirm, when you run scope.upgrade_firmware(), it gets to the “Verifying…” step and appears to get stuck there, i.e. you never get the “Verifying OK!” message?

Yes,
Oh, I solve this problem by shorting erase pin and reprogramming cw1200.

Thanks

1 Like