Problem with the Capture Board


#1

Hi,
I got a bunch of errors while programming the CW303 using Tutorial 5:
Response length from target shorter than expected (0<34)
Timeout in OpenADC capture(), trigger FORCED

Checking the forum, I came across this post: viewtopic.php?f=7&t=357
Tried to update the SAM3U Firmware, which threw an error and then it would not recognize the USB as well!
Also, the LEDs are very dim now whenever the board is connected.

Please help me resolve the issue.
ChipWhisperer-Lite, Serial Number = 44203120473539413130343137313034

Thanks,
Debayan


#2

Hi Debayan,

To confirm, when you say you were programming the CW303 for tutorial 5, you were flashing firmware onto the target (probably via the XMega programmer)? Typically your first error message occurs during a capture if the trigger pin doesn’t go high or it doesn’t receive a response from the target. Did you make sure that the target had the correct firmware on it? The target is the microcontroller on the smaller side of the break off section.

As for your second issue, have you tried unplugging the ChipWhisperer and replugging it? Otherwise, the firmware may have been corrupted. If that’s the case, wiki.newae.com/Manual_SAM3U_Firmware_Update should be a pretty reliable way to resolve your issue.

Let me know how that goes.

Alex


#3

Hi Alex,

Thanks a lot for your response.
I am using the CW-lite 2-part version. I was able to update the firmware and get the capture board (CW1173) running (LEDs are blinking correctly now).

Also, flashing the target board made it work. I am not sure why the flash got erased from the CW303 target board though!

Regards,
Debayan


#4

Happy I was able to help! Let me know if you have any more issues/questions.

Alex