Some errors in mac El Capitan

Hi, everyone

I tried to run the software on my Mac, but I got some errors…

OS: El Capitan
Python version: 2.7.12 ( the latest Python2 on hombrew )
Software version: 0.12RC ( from … e_Releases )

I can open CWCapture, but got a warning
libpng warning: iCCP: known incorrect sRGB profile

Unfortunately, I cannot open CWAnalyzer, and got a warning and an error
libpng warning: iCCP: known incorrect sRGB profile
raise TypeError(“Invalid keyword argument ‘%s’.” % k)
TypeError: Invalid keyword argument ‘set’.

btw, when I want to run CWAnalyzer on my virtual machine, windows7 64bit, I got the same error , too.

hope some help, highly appreciated :smiley:

Current version is 3.2.0. Try to checkout/pull the last version from the git repository: … git/source

Thanks for your reply!
I tried to clone the new version from your link
Now, I can open CWCapture and CWAnalyzer, but it seems that it cannot find several modules…
Does it matter?
I got the following messages when I opened CWCapture and CWAnalyzer


I post 2 pictures though they look the same…
btw, my environment is the same as the previous post
Although, the link is outdated, I follow the instructions of
to install things I need via home-brew and pip. ( I install PySide via pip )

It’s ok, it is just an info, not a warning or error. It means that CW tried to load some modules for more exotic target/scopes but they were not instaled/configured. It is not a problem as long you don’t use them (as is the case of most people).

The rand warning at the end means that it will use the python rand() method to generate random keys/plaintext. In theory the AES random method would have better quality if you opt to install (most people will not).

I use it on Chipwhisperer Lite, but I cannot do a CPA, and find the key even on the example scripts… ( Chipwhisperer-Lite: AES SimpleSerial on XMEGA
At beginning, I think that’s because I did not install something…
Now, it seems that I get something wrong in other parts…

Follow the updated tutorials at:

They should work out of the box. Tell me later if they are not working for you.

Try running the automated test script:
python chipwhisperer/software/chipwhisperer/tests/

It should automatically flash the target, capture the traces, and analyse it to extract the key. If it is not working for you than you have an installation problem for sure.

Thanks! I can successfully run the script, and some of my implementations, too!