Upgrading firmware

I enter the bootloader by mistake and since then the screen is black.
I have tried all the solutions that I could find in the documentation and in the forum.
I am using cw1200 on windows. When I connect the USB I see under Ports(COM & LPT) - AT91 USB to Serial Converter(COM 23)
I have the binary file - CW1200_SAM3UFW.bin
I also downloaded BOSSA.
When I try to write the binary file using BOSSA I receive the message - “The flase is corrently locked. Do you want to unlock it and proceed with the write?” Yes / No
After pressing Yes I receive the massage - Flase page is locked. (and the writing is failed)

I also try to use the jupyter:

import chipwhisperer as cw
programmer = cw.SAMFLoader(scope=None)
programmer.program(‘COM23’,fw_path=‘my path to binary file…’)
it is working until the the massage:
programing file ‘my path…’

and the i get error:
OSError : Timeout

any ideas?



I’m not too sure how the lock bits got set here. You should be able to clear any security/flash lock bits via the erase pin on the PCB.

Colin describes the process in this thread: Failed to Update Firmware of CW1200, ChipWhisperer-Pro


I tried to erase the flash using the erase pin.
right now I can see "BOSSA Program Port(COM26) in the device manager under Ports.

When I use the code:
import chipwhisperer as cw
programmer = cw.SAMFWLoader(scope=None)
programmer.program(‘COM26’, hardware_type=‘cw1200’)

I receive OSError: Timeout

The same happen when I try to program with:
programmer.program(, )


OK I figured it out. I didn’t erase the flash properly.
It is working right now after programming via BOSSA.