Discussions on Python software that powers the ChipWhisperer system
#1248 by south
Fri Apr 14, 2017 2:16 am
Hello,

I am new on this topic, so be indulgent please :-)

I am using Chipwhisperer Lite version. I have installed the 3.3.0 version inside a Virtual box running Lubuntu (lite Ubuntu) on a Mac Book pro computer.
It works fine. I have realized the tutorial B5.

But when I want to plot the output vs point plot, the CWAnalyzer crashes completely with this prompt error:
INFO:Redrawing Output vs Point Plot: 0.0% (Plotting...)
INFO:Redrawing Output vs Point Plot: 100.0% (Plotting...)
Killed
No more information about the problem...

I have also a second issue:
I have tried to increase the number of points by acquired trace (set to 20000) inside CWCapture. Then, I perform CPA attack and the analysis begins and crashes :
INFO:Executing analysis...
INFO:Analysis in Progress: Attacking with CPA
INFO:Analysis in Progress: Initializing...
INFO:Analysis in Progress: Attacking traces subset: from 0 to 49 (total = 50)
INFO:Analysis in Progress: 0.0% (Trace Interval: %d-%d. Current Subkey: %d)
INFO:Analysis in Progress: 0.0% (Trace Interval: 0-9. Current Subkey: 0)
Killed
DEBUG:Deleted: <chipwhisperer.common.ui.ProgressBar.ProgressBarGUI object at 0x7f695a529518>
[1]+ Segmentation fault (core dumped) python CWCapture.pyw

If someone has an idea to solve this, it would be very nice. Thanks by advance.
Regards
#1249 by gdeon
Mon Apr 17, 2017 8:33 am
Hi there,

I hope you're enjoying the ChipWhisperer (other than these problems...)!

I haven't seen these crashes before and it's tricky to debug them without much info. I'll see if I can reproduce them on my computer. Are you using VirtualBox or VMWare Player? Are you using the VM that we release on GitHub?

Let me know if you find any more clues too!

Who is online

Users browsing this forum: No registered users and 1 guest