Discussions on Python software that powers the ChipWhisperer system
#1456 by florenzo
Thu Jul 13, 2017 2:21 pm
Hello,

I'm having some problems with regards to the last step on the tutorial. For some odd reason, whenever I try to capture signals, my Text In and Text out are always the same. So far, all the captures I've made have failed and I don't know why. Also, my power trace always seem to look like a steady line as if it's not capturing anything. Any help would be appreciated.
#1462 by gdeon
Fri Jul 14, 2017 8:08 am
Hi Florenzo,

I agree that this tutorial is a bit misleading! Here's what's going on.

First, this tutorial is just showing how to load firmware onto the XMEGA target. The simpleserial-base firmware doesn't actually do encryption - it just leaves the textin unchanged. (You can modify this behaviour to do whatever you like - the tutorial shows how to increment each of the textin bytes.)

However, the encryption status monitor is programmed specifically for AES: the Expected field shows the output of AES encryption using the textin and key as the plaintext/key pair. This means that your textout definitely won't match the expected values because you're not doing AES encryption. In other words, it'll look like every capture fails because they're supposed to right now!

The picture in the tutorial is misleading because it shows the wrong textout values - I'll fix this soon.

By the way, it's okay that the power traces are pretty flat: you're basically not doing anything with the textin values, so the XMEGA won't use much power. Things should make more sense in tutorial B2.

Who is online

Users browsing this forum: No registered users and 1 guest