Break RSA on XMEGA

Hi! I am trying to run the script /jupyter/courses/sca202/PA_SPA_2-RSA_on_XMEGA_8bit.ipynb, but get warnings and error such that no traces are captured. What am I doing wrong? Help much appreciated!

(I am using CWLITE together wit CW308T-XMEGA target board on an UFO board)

Your target isn’t responding. Try a reset_target(scope) and then try the capture_RSA_trace() again.

If this still fails, what is the output of print(scope.clock, target)? Are you able to run other notebooks e.g. one of the AES attack notebooks?

Jean-Pierre

Thank you for your response! I tried reset_target(scope) and got the same errors and warnings. Here is the output of print(scope.clock, target).

I have successfully done many of the tutorials using the STM32F target board (instead of the XMEGA board) together with UFO board. Now I tried for instance the PA_DPA_3-AES_DPA_Attack.ipyng using XMEGA, and get the same warning " Timeout in OpenADC capture(), no trigger seen! Trigger forced, data is invalid." But in that case traces were captured anyway…

I am wondering if there are any changes that must be made on the UFO board, like with the jumpers or anything. I am quite new to ChipWhisperer, so there might be some basic stuff I have missed.

If your UFO settings worked for the STM32 target, you should be fine here. Firmware compilation and programming worked cleanly?

Thank you for your fast response! Yes, firmware compilation and programming target works fine :slight_smile: