Bricked the chipwhisperer? - help needed


#1

Hi,

I may have accidentally bricked the chipwhisperer.

I did not use the chipwhisperer for quite some time, when I used the red right light on the chipshisperer (which usually blinks when I’m in the firmware update mode was lit). Now, I tried replacing the firmware (Sam3U) and used the chipwhisperer VM to do that). As soon as i entered the firmware update mode, a faint lit red and blue light started to appear.

Now I’m not able to exit or update the firmware (I tried BOSSA update utility too). Is there anything I can do ?

thanks for the help.


#2

Hi Erin,

I hope your ChipWhisperer isn’t bricked!

The faint red/blue LEDs are a signal that the ChipWhisperer has no firmware and is waiting to be programmed. From there, to get it back to health:

  • Plug in the CW-Lite. Make sure a serial port device appears on your computer - on my laptop I see a serial port on COM13.
  • Since you’re using the VM, make sure the serial port device is passed through to the VM.
  • Open CWCapture and go to Tools > CW Firmware Preferences > Open SAM3U Update Widget.
  • Select Built-in, click Update List, then Run Program.
    Let me know where you get stuck.

#3

I tried following the steps, however, the VM recognises the chipwhisperer as “Atmel BOSSA Program Port” and when I use chipwhisperer software to program the firmware, the chipwhisperer capture software shows an error - chipshiwperer not connected.

I believe i need to update the firmware using BOSSA utility on my primary OS (Windows). However, I am not sure where is the firmware for the same. Any links to the SAM3U firmware ?


#4

Wow - that’s a pretty bad bug on our side. It’s impossible to open the programmer window without connecting a ChipWhisperer…

I’ll write a quick fix for this bug. In the meantime, the default SAM3U firmware is here: https://github.com/newaetech/chipwhisperer/blob/develop/hardware/capture/chipwhisperer-lite/sam3u_fw/SAM3U_VendorExample/Debug/SAM3U_CW1173.bin


#5

I’ve pushed v3.4.3 onto Github - if you run git pull in the VM it should update your software and let you program your CW-Lite normally (via the software).


#6

Thank you so much. Will update you on this :slight_smile: .


#7

Hello,

I tried updating the firmware, no luck
Got an error

An error has occurred:
Could not configure port: (5, ‘Input/output error’)

It is usually safe to continue, but save your work just in case.
If it persists, try reseting the settings first before creating a new ticket informing the details bellow.

traceback (most recent call last):
File “/home/cwuser/chipwhisperer/software/chipwhisperer/capture/scopes/cwhardware/ChipWhispererSAM3Update.py”, line 189, in runSamba
sam.con(self.serlist.currentText())
File “/home/cwuser/chipwhisperer/software/chipwhisperer/hardware/naeusb/bootloader_sam3u.py”, line 47, in con
bytesize=serial.EIGHTBITS
File “/usr/local/lib/python2.7/dist-packages/serial/serialutil.py”, line 282, in init
self.open()
File “/usr/local/lib/python2.7/dist-packages/serial/serialposix.py”, line 296, in open
self._reconfigurePort()
File “/usr/local/lib/python2.7/dist-packages/serial/serialposix.py”, line 325, in _reconfigurePort
raise SerialException(“Could not configure port: %s” % msg)
SerialException: Could not configure port: (5, ‘Input/output error’)

I also tried the BOSSA utility, no luck, the firmware updates, however the chip remains the same.

Thank you for replying. :slight_smile:


#8

That error sounds like the computer can’t find a connected ChipWhisperer. A few things to think about…

  • Are you sure that you selected the right COM port? Do you have anything else connected to the computer that runs as a COM port?
  • Now that you’ve programmed something onto the CW-Lite with Bossa, how does the device appear on the computer? Is it a ChipWhisperer-Lite or an Atmel programmer device?
  • Maybe the CW-Lite got partially programmed (something failed partway through a programming cycle). You can try again by erasing the code on the Lite: short circuit the ERASE jumper (on the bottom right), then power cycle the ChipWhisperer. Then Bossa or the CWCapture programmer might work again.

#9

It shows as BOSSA ATmel program port, I did short it using a jumper cable, but nothing seems to move. The blue/ right lights are consistent. The programmer doesn’t seem to work :frowning: .


#10

Hi Erin,

Trying to solve here & wondering if another driver issue - can you email sales@newae.com so can grab some additional details for you to solve this?

Thanks,

-Colin