Bypassing LPC 1114 problems


I ran into an issue with the LPC 1114 fuse bypass tutorial. I connect it and everything, but I have some problems.

  1. I tried to run this code block. But when the 6 raw code ran, my chip sometimes turned off. In this case, I checked the power pin with osilloscope, I could see the chipwhisperer didn’t offer the power to chip. So, What is the role of 6 raw code and Why the problem occered?

  2. Anyway, upon problem sometimes occured. So if it didn’t occured, I could perform glitch injection. I could see the glitch through my osilloscope after nrst signal. But anything happened!!!. Of course, I changed the glitch parameters(repeat, offset). So I want to know the exact values of those parameters that you can succeed.


This is hard to diagnose, but based on this and your previous post, it sounds like your target is not operating correctly; I would double-check that all the target modifications have been made correctly and that you have no shorts.

Um, actually I didn’t use the same dev board used in the tutorial, but I use another dev board which have same chip(LPC 1114). So, I tried to make same condition with tutorial. I mean I make same target modifications using pin map.

Compared to upon original modifications,

  1. I short PIO0_1 to GND to put the device in bootloader mode.(BLD_E is connected to PIO0_1 in orignal dev board)
  2. Solder a wire GND to P0_3(make same modification)
  3. Remove all bypass capacitor.
  4. No trace in my dev board.
  5. Add a 12 ohm resistor between 3.3V & CW
  6. Add an SMA connector to the board and connect VCC … (make same modification)
  7. Add a header pin/wire to RST… (make same modification)

then, I think I connect lpc1114 and chipwhisperer correctly after this modification.