ChipShouter high voltage fault

Hi,

When the voltage is changed during glitching, sometimes a ‘fault_high_voltage’ fault is triggered. This happens fairly randomly, sometimes not happening for 500+ changes and other times happening every few changes. I tried reconnecting every cable used to be sure they are plugged in correctly. I am using the provided 1.5mm tip attached directly to the ChipShouter. It also seems like the only way to fix this issue is by completely powercycling the ChipShouter, just clearing the faults will cause the same fault to appear when the voltage is changed again.

I have provided some data below which happens with the following code. The ChipShouter state was ‘armed’ before changing the voltage, after which it was changed to ‘fault’.

cs.voltage = cur_voltage
if (cs.state != ‘armed’):
print(“ChipShouter fault detected”)
# Dump info about ChipShouter

Old: 425
New: 450
Measured: set = 450
measured = 63

Old: 450
New: 475
Measured: set = 475
measured = 25

Old: 475
New: 500
Measured: set = 500
measured = 22

The ChipSHOUTER will disarm itself after a while. Have you tried rearming it after you start seeing lower voltages?

Alex

The state right before changing the voltage is ‘armed’ and the ‘READY’ LED was on. It also happens fairly inconsistently so I doubt this is the normal disarm timer.

Is the device being discharged in this case, or are you just arming it and changing the voltage?

Alex

I am guessing the fault occurs when changing the voltage, as the state right after is changed from ‘armed’ to ‘fault’. So it seems like it does not happen during a discharge, but when the device is armed and the voltage is changed.

Alright, I’ll see if I can replicate this and investigate further.

Also, another thing: I believe updating the voltage repeatedly like this will hammer the EEPROM with writes. We’ve got a firmware update that fixes this by only writing via a specific command, so if you’d like I can build new firmware for you and send it to you.

Alex

Another question: when you say you need to power cycle to fix the issue, does the issue arise only when you try to change the voltage, or upon rearming?

Alex

The same thing happens when I only change the voltage every 30 seconds. It will just take longer to happen obviously.

I will have to check as I did not pay attention to this.

I think the fault occurs when firing a glitch. I reconnect to the ChipShouter and clear all the faults using ‘cs.faults_current = 0’.

Two more questions:

  1. How close is the voltage to the set voltage when this isn’t occurring?
  2. When you change the voltage, does the response from the chipshouter ever seemed delayed (it might be easier to notice this if you use the serial console instead)?

Our suspicion right now is that the voltage measurement on your CS might be a bit more variable than normal. The usual threshold for a fault is 10%, but we can relax it a bit and see if that fixes it for you.

We’re currently doing a new run of ChipSHOUTERs, so it might be a bit before we can get you a replacement, but hopefully a firmware update with a relaxed voltage requirement can at least get you running again consistently.

As a follow-up to your earlier question, after clearing the faults, the same fault will occur again when arming the ChipShouter. The arming tone is also very stretched out, like it is lagging.

As for your other questions:

  1. When everything is working normally, it is usually about 0 to 3V off but this is sometimes higher. The highest I have seen is 16V difference at 346V, but this didn’t trigger any faults.
  2. The ChipShouter occasionally becomes very unresponse, to the point where commands take upwards of several seconds to complete. Most times, this is gone once the device is armed/when we start glitching, else the delay will stay and doing 1 glitch can take several seconds to complete. Re-plugging the RJ12 cable usually fixes this issue however.

What is the best way to share the board id for the firmware update?

You can just DM your board ID and I can share the firmware update via DMs as well.