ChipShouter raise probe fault during long time test

Hello everybody,

I get the following fault message:

  • “Probe Fault” (via serial port) and
  • The Fault and Open LED lights up

The fault occurred during a continuous run after 2 days, whereby 1 pulse (490V and 80ns triggered via hardware) was generated per second.

A 4mm CCW tip was connected via a 10 cm long coaxial cable.

Try to fix the fault:

we tried to reset and power cycle the chipshouter and change the tips to a not used one.
we tried to press the arm button for 8 seconds and to send the “set fault none” command without success.

we then replaced the chipshouter with a new one and after around 20,000 shots we have the same fault.

What did we do wrong?
How can we reset to a normal state?
And what do we have to do to repair the two ChipShouters?

best christian

Hi Christian,

Hmm - this is definitely unusual! You shouldn’t see that error happen normally (we do many millions of test pulses now without issue). We don’t normally use a coax on the end out of concern from ringing etc - although I wouldn’t have expected damage to happen there. This happens if the tip is directly connect as well right (i.e., not the SMA cable opening)?

Before looking at HW issues it might be something easier to fix…

We realized there was a bug in the firmware for the EEPROM writing, causing many(!!) more writes than should happen in some use cases (specifically, if you are varying settings on each pulse it does an EEPROM write with them, which can kill the EEPROM. The faults also get saved to EEPROM so if the EEPROM isn’t working correctly it might never “clear” the fault.).

Luckily it’s almost always fixable with firmware - the new version of the firmware (working on now) now only writes when you request it. It also uses a different EEPROM page so everyone will be starting at “day 1” with their EEPROM lifetime (i.e., regardless of if you saw issues or not we’ve mapped out the problem EEPROM). The firmware is built “per unit” so will need your board id to build it - if you can email support -AT- we can open a case for you to get the details to you. There was another post on the forum with the update procedure as well, but we’re working on making it even easier…

Re - repair service if this doesn’t work. They could still be under warranty (it doesn’t sound like you’ve used them in a way I’d expect damage), but can contact you via email to sort out. We haven’t done out of warranty repairs yet but something we may… so far the (reported) failures have been low enough we haven’t had to sort that out yet!