Chipwhisperer Analyzer V2


usually i opened Chipwhisperer Analyzer via Spyder. when i opened the program i got an this error:

Traceback (most recent call last): File "<stdin>", line 1, in <module> File "C:\WinPython\python-2.7.6.amd64\lib\site-packages\spyderlib\widgets\externalshell\", line 540, in runfile execfile(filename, namespace) File "C:/chipwhisperer/software/chipwhisperer/analyzer/", line 745, in <module> main() File "C:/chipwhisperer/software/chipwhisperer/analyzer/", line 738, in main window = ChipWhispererAnalyzer() File "C:/chipwhisperer/software/chipwhisperer/analyzer/", line 105, in __init__ self.results = ResultsPlotting() File "c:\chipwhisperer\software\chipwhisperer\analyzer\", line 72, in __init__ self.graphoutput = OutputVsTime() File "c:\chipwhisperer\software\chipwhisperer\analyzer\", line 467, in __init__ super(OutputVsTime, self).__init__() File "c:\chipwhisperer\software\chipwhisperer\analyzer\", line 209, in __init__ super(ResultsPlotData, self).__init__() File "c:\chipwhisperer\software\chipwhisperer\common\", line 166, in __init__ layout.addWidget( TypeError: 'PySide.QtGui.QBoxLayout.addWidget' called with wrong argument types: PySide.QtGui.QBoxLayout.addWidget(PlotWidget) Supported signatures: PySide.QtGui.QBoxLayout.addWidget(PySide.QtGui.QWidget, int = 0, PySide.QtCore.Qt.Alignment = 0)

winpython command didn’t open program

cd C:\chipwhisperer\software\chipwhisperer\analyzer python

by the way i saved my project file *cwp file but analyzer didnt open my file. i selected my project but i dont see anything.

for example, i tried to open enabled/disabled modules in Analyzer but suddenly dissepear didnt open. :confused:



i solved the problem, i downloaded WinPython-64bit- then analyzer seems working =)

but this time, capture couldn’t connect the scope:

what should I do? :frowning: