Chipwhisperer install issues macOS


#1

So I’m running macOS High Sierra (10.14.1) and having trouble getting the CW software to run. It seems to be an issue with PySide/qt4?

Here’s is the error output when I try and start the capture software

And here is a pic showing I’ve got all the required packages installed?
58%20AM

I’ve tried removing both PySide and qt4 and reinstalling them so I know the dependencies are there. Any ideas?


#2

Hi Tim,

I believe the issue you’re having comes from the brew install of PySide not being in the python path (where it searches for packages). You can try:

  1. Adding the PySide install location to the python path (export PYTHONPATH=$PYTHONPATH:/path/to/pyside). I’m not sure where brew installs PySide to and don’t have a Mac to check, so this option’s probably a little harder.
  2. Install PySide via pip (described here after the brew install instructions: https://wiki.newae.com/Installing_ChipWhisperer#Manual_Install_-_Mac_OS_X)

Let me know if that fixes things,

Alex


#3

So I tried removing brew’s PySide install and then installed it via pip. everything went fine but now getting this error

Edit: I did check brew’s install path and as you suspected it wasn’t installing PySide in the usual spot


#4

Hi Tim,

A quick search found this https://stackoverflow.com/questions/25656307/pyside-qt-import-error. Can you try updating your DYLD_LIBRARY_PATH?

Alex


#5

lol I guess I’m gonna have to sit here googling error messages until there’s none left. I was hoping that it was a quick fix with just the QT error. On the plus side once it’s worked out I can do an updated writeup on the macOS install instructions to hopefully save someone the headache.

Anyways here’s latest error


#6

I tried installing CW through pip and after running chipwhisperer-cap I got all these errors. I guess it’s a bit more telling of the issues than the previous


#7

Unfortunately it seems the PySide installer has been broken on Mac for a while (some of the posts in that stackoverflow link are from 2014). This hopefully shouldn’t be an issue in the next version of ChipWhisperer, since we’re moving away from using PySide or a GUI entirely.

If you get really stuck on the PySide installation, you can try moving over to the cw5_dev branch on git, which removes PySide. It hasn’t been tested at all on Mac yet though, so I can’t promise installation will be any smoother.

Alex


#8

Yea I noticed that most of the posts regarding macOS and PySide were from many years ago which I why I figured I’d check in here. I guess I’ll keep fiddling with it for a little while longer and if all else fails I’ll switch to my Windows bootcamp partition. Thanks for trying to help :slight_smile:


#9

Happy to (at least attempt to) help.

Let me know if you run into any more issues,

Alex