ChipWhisperer Lite won't get connected to the device

I’m a PhD student at IISc Bangalore working on Hardware Security using ChipWhisperer Lite and XMEGA Target Board.
After connecting the chipwhisperer I ran the below code:

import chipwhisperer as cw
scope = cw.scope()
This shows thatThe firmware was outdated please upgrade to latest version

After going to the tutorial given on the link:

I upgraded my firmware, a faint RED and BLUE light is showing on the board.
And then running the same code for connecting chipwhisperer
The following message shows up:

import chipwhisperer as cw
scope = cw.scope()
Traceback (most recent call last):
File “”, line 1, in
File “C:\Users\Acer\AppData\Local\Programs\Python\Python311\Lib\site-packages\”, line 384, in scope
scope_type = get_cw_type(**kwargs)
File “C:\Users\Acer\AppData\Local\Programs\Python\Python311\Lib\site-packages\chipwhisperer\common\utils\”, line 522, in get_cw_type
device = cwusb.find(serial_number=sn, idProduct=possible_ids, hw_location=hw_location)
File “C:\Users\Acer\AppData\Local\Programs\Python\Python311\Lib\site-packages\chipwhisperer\hardware\naeusb\”, line 344, in find
raise OSError(“Could not find ChipWhisperer. Is it connected?”)
OSError: Could not find ChipWhisperer. Is it connected?

Everything is working fine like drivers and all but the ChipWhisperer is not able to connect to the device.
Anyone facing the same issue, it happens after the firmware upgrade.
I have also tried to erase the pin by shorting the J2 but the situation is still the same.
Need a solution to this problem.


Your device is probably still in bootloader mode. Try running this code: Updating Firmware — ChipWhisperer 5.7.0 documentation