Could not detect STM32F


I re-plugged my chipwhisperer lite on my macOS.

I am not able anymore to program my STM32F3 target, here is my process:

In [1]: import chipwhisperer as cw
In [3]: PLATFORM = ‘CW308_STM32F3’
In [4]: scope = cw.scope()
In [5]: target =
Serial baud rate = 38400
In [6]: prog = cw.programmers.STM32FProgrammer
In [7]: fw_path = “…/hardware/victims/firmware/simpleserial-rsa/simpleserial-rsa-{}.hex”.format(PLATFORM)
In [8]: cw.program_target(scope, prog, fw_path)
Serial baud rate = 115200
Serial baud rate = 38400
Failed to detect chip. Check following:

  1. Connections and device power.
  2. Device has valid clock (or remove clock entirely for internal osc).
  3. On Rev -02 CW308T-STM32Fx boards, BOOT0 is routed to PDIC.

    OSError: Could not detect STM32F, check connections, BOOT MODE entry setup

I am not sure to understand why I am not able anymore to reprogram my target. I did not change anything. But I have migrated to macOS 10.15.4 and updated Xcode 10.2.1 (10E1001).

How did you install chipwhisperer? VM or natively?

I’d expect the mac update broke something.

I installed it natively with last release. “python install”

I re-installed it just to check, but same issue…

Thank you

I don’t have Mac to reproduce that.
Did you try on different jupyter notebook? e.g. instruction differences

Did you use CW308_STM32F3 on purpose? I’m normally using:


And finally do you have all wires connected? and CPU is powered on?
Normally the red led should be on :slight_smile:

I also tried with a CW308_STM32F0 and different jupyter tutorials.

Here is a photo of the setup :

On the chipwhisperer fpga, only a blue light is blinking. Maybe I have an issue with the firmware …


On the 308 are red leds on (LED1,2 or 3)? I think they are off, but they might by very very weak.

Could you try power from external power supply? Or try different positions of 3.3V SRC and 3.3 LDO SRC switches. Because I see 3.3V SRC is set to LDO and LED is very weak and 3.3 LDO SRC is set to EXT-DC. To fix that there are two options:

  1. Connect external power supply via barrel jack and don’t change switches.
  2. Change 3.3V SRC switch to J1/CW and don’t connect power supply.

I hope it helps


1 Like

Thank you @31415 it works !

I did the second solution, change 3.3V SRC / and 3.3V LDO SRC to J1/CW and I am now able to flash the STM32F3 ! I will read the documentation to understand what is the LDO SRC.


Great :slight_smile:

You will need this diagram:

On this digaram:
“3.3V LDO SRC” is S4.
“3.3V SRC” is S2.

You tried to power target CPU from LDO and LDO was set to EXT-DC, but without barrel jack.

If you power from the chipwisperer, use only “3.3V SRC” and turn off unnecessary LDOs, because all power comes from you USB port and you are powering a lot of different components and random problem can occur. From this reasons, I’m using barrel jack to do not worry about power issues anymore.

If you want to see better detailed diagram scroll down to the schematics on this site:

1 Like