CW-Nano capture timeout

Hi guys,
having trouble in the sca101 LAB “Connecting to Hardware”.
Keep timing out when trying to capture traces using cwnano.
(I tried using simpleserial2 and playing around with bytes being passed to simpleserial_write)
Is capturing traces a known difficulty with the nano?
I’m on ubuntu20.04 (not inside VM)

thanks for your time in advance

this is how I built the firmware for the target


I think the issue is with msg = b"0011...". While that has the type bytes, it behaves more like a string in that 00 is 0x3030, not 0x00. I’d recommend using a bytearray object instead.


Hi Alex,
Thanks for the reply.
Yes I tried a byte array (of varying sizes).
But that was also not a solution.


What bytearray lengths have you tried? The length of the bytearray you pass to simpleserial_write() must be exactly 16 bytes long, otherwise the target will reject the packet.

You may also want to uncomment the code that prints "hello\n" at the beginning of simpleserial-base to verify that serial is working in general. If you run print( after programming, you should see "hello" if serial is working.


Awesome thanks Alex!
I’ll give this a go tonight after work

I updated the firmware (as you kindly helped me resolve) and will try again now to run the hardware setup with an up to date nano.

I upgraded the firmware on my nano to

Then moved back to chipwhisperer version 5.5.0

and now the serial connection is working properly.
Thanks for all of your help Alex.

1 Like