CW1173 bootloader is no where to be found

Dear all,

I got issues about my CW1173 whose bootloader is not able to be detected by my ubuntu 22.04 LTS. It used to work but after a while it suddenly doesn’t work anymore. I try to erase the firmware on it following the instructions here. However, the CW1173 is still not visible by command ls -l /dev/ttyUSB*. (Even ls -l /dev/ttyACM* does not work). Any idea how to detect the bootloader again?

Thank you all in advance!

Did you try:

import chipwhisperer as cw

Yes, the response is:
Could not find bootloader serial port, please see Updating Firmware — ChipWhisperer 5.7.0 documentation

I can see the dimmed LED lights on the board btw

If it used to work on this computer and nothing else has changed, maybe there is a problem with the connection; can you try a different USB port / cable / computer?

I tried with other cables and other computers. It is still not working.

I also tried on WIndows but the device manager cannot detect anything either

Can you try shorting the erase jumper as shown at CW1173 ChipWhisperer-Lite - NewAE Hardware Product Documentation?

Yes, I have shorted the device and device now have LEDs displayling like that.

Can you post the result of sudo dmesg | grep USB?


The ChipWhisperer You saw is the other one I used yesterday, not the problematic one. The problematic one’s info is not shown here.

Just to confirm, was the malfunctioning ChipWhisperer plugged in before you ran dmesg?

Yes. I saw the dimmed LEDs.