CW1173 stopped working


#1

Hi,

My CWlite suddenly stopped working this morning. :worried:.
Yesterday I worked with CW all night and everything worked fine, and I disconnected it and went to bed. This morning I connected it again and CW no longer worked…

  • When I connect USB cable the red and blue led turns on shortly and then turns off again.
  • No USB device is detected when I plug-in CW in Windows 10.
  • All SAM3U input power supplies are 3.3V
  • VDDOUT is 1.8V
  • NRSTB is high, Erase is high.
  • PWRON is low hence no power to VBUS_SWITCHED and +5VCLEAN
  • I do not have an oscilloscope so I cannot measure XIN (Q1)
  • Tried multiple USB cables… no luck

I then did an erase with Jumber JP2 and repowered.
The led’s then went constantly on in a dimmed light. Still not USB connection though.
I then connected an FTDI to UART and programmed the firmware again using Bossa.
Programming was successful, but the CW just went back to previous mode… no USB and red and blue led only turns on shortly… not heatbeat.

Have anyone experienced anything similar? Any ideas on what to check?

It seems like the device is kept in reset or that the clock is not running.
As far as I know SAM3U has both an internal and external xtal and automatically tries both during initialization.

I may need to get an oscilloscope to measure for any activity.
Perhaps go through all solderings on SAMU3.

Best regards,

Wess


#2

Have you tried reprogramming it through the USB cable instead, as per the instructions here:
https://wiki.newae.com/Manual_SAM3U_Firmware_Update

Jean-Pierre


#3

Yes, I did try but without success because CW is not detected by device manager and therefore no driver could be installed.

Wess


CW Lite FPGA programming issues (macos)
#4

Just an update. (Solved)

I finally got hold of an oscilloscope and apparently clock etc. worked fine.
Debugged through UART and no problems there no errors from the SAM3U.
I was about to come to the conclusion that i must have fried my USB on SAM3U and ordered a new MCU just in case.

I then decided to test every single detail, and started with the USB path.
Measuring with my Fluke i realized that i could not measure connection from the USB-A connector to the ESD protection diode. New cable same fault… third cable same fault.
Hmm, I then measured USB connector on CW … connection fine :thinking:
I finally decided to steal my sons USB cable from the playstation :smirk:
Now everything works fine the CW is again detected and CPA analysis working again… dooh.

What is the chance of me taking three independent USB cables all giving power to the board and all having data connection issues… apparently 100%

Well thx for lending ear to my problems…

/Wess


#5

That’s great, thanks for reporting back.
It’s sad how much time we lose as a result of bad cables!