CWNano bricked and invisible on both Windows and Linux

I recently had issues with the chip whisperer nano in that it wasn’t recognized by my Linux system anymore in any way. It previously was working after doing the setup shown on ReadTheDocs.

I tried then to reset the CWNano by shorting the erase pins on the back. This led to the CWNano showing dim LEDs when attached to the USB, but now I cannot access it in any way, on any OS and it is now stuck in (what I suppose is) bootloader mode.

On neither of the system does the CWNano show up: on Linux lsusb doesn’t show any new device and ls -l /dev/ttyUSB* (or ls -l /dev/ttyACM* for that matter) doesn’t show any matches. On Windows, the serial port doesn’t show in the device manager, even after installing the drivers contained in the hardware folder of the repo or even after installing BOSSA.

This is what I’ve currently tried on Linux (on both my Arch Linux install and Ubuntu 18.04 on another computer):

  1. This trick with modprobe
  2. Restarting the system several times on Linux
  3. Changed the USB cable
  4. Changed USB ports

On Windows, I tried to install the drivers, BOSSA, and I’ve followed the steps shown on the “Driverless Windows” section of the ReadTheDocs here.

Nothing has worked so far, have I missed something?

Thank you in advance for any advice on this issue, I’m looking forward to experimenting with the CWNano and, unfortunately, I cannot get it to work.

Based on the dim LEDs, you should be in bootloader mode. The device is just a USB CDC device, so you shouldn’t need to install drivers on Windows.

When looking on Windows, make sure you have your VM closed, as it will prevent the bootloader from showing up in Device Manager.


Hi Alex, thanks for the response!

I am not currently using a VM: my objective was to use this tool ( to flash a new firmware on it but I cannot do this since the device doesn’t show up on the device manager to start with (No COM ports are shown on windows)

Oh whoops, I saw the Linux stuff and assumed it was the VM.

On Windows, can you download and run USBTreeView and see if you can find the bootloader in there?

I’d say also inspect the pins on the microusb connector (inside and outside), just to make sure they’re not visibly broken or something.

Also, just to make sure, you’re using Windows 10, correct? I’m not too sure what serial port stuff looks like on earlier versions of Windows.

Also, if you’re able to get it working, make sure you use the firmware updater from our newest release:

The bootloader unfortunately doesn’t show on USBTreeView. However, I’ve looked at the pins very carefully and I do not see any signs of damage, both inside or in the connection of the USB port to the rest of the chip.

Indeed I am using Windows 10

Also thank you for the new link for the firmware updater!

Are you running your device off a USB-A (old style) or a USB-C port? We’ve seen issues with USB-C ports
in the past.

I’ve tried both and it does not appear to change (I’ve tried all of the ports on my PC, both my PCs actually, and I’ve gotten no results on either and I know that there are at least 2 USB-A ports on there).

I think I’m still on time to return the product to mouser so if this is particularly anomalous and there is no immediate way to fix it I believe that, at the very least, I can get my money back.

Hm, yeah, I’m pretty stumped. If even the bootloader doesn’t work, it’s probably a hardware issue. I think it’ll be easier if we just send you a new one. Can you email with your address so we can get you a new Nano?


Thanks you very much! That would be awesome!

Kind of a shot in the dark here, but do you know the series of processor your computer has (intel/amd processor generation)?

I am currently using a computer which is quite old as my main one, the processor is a Intel i7-3630QM (it’s part of the Ivy Bridge family, so 3rd gen). This is the pc which I was using when I flashed the firmware on the CWNano.

For testing if the CWNano was still working (just before making the post) I also used another pc with an Intel i5-7Y54 (Kaby Lake, 7th gen), again to no avail.

Thanks for reporting your specs! I’ve seen USB issues on the Ryzen CPUs specifically (not just with our device), so I wanted to check and make sure it wasn’t that.


I just got the new CWNano so first off let me start by thanking you a lot for being so kind in replacing the chip so quickly! I’ve started playing around with it as soon as I got it and I noticed that it feels like it’s going a lot smoother than the first time (I had some issues with capturing traces with the old chip in the tutorial notebook for some reason!). I guess it was indeed the hardware after all :slight_smile:

Thank you again and I guess we can close this thread!

1 Like