Device failed to ack - Large Hamming Weight

When going through Lab 3_1 - Large Hamming Weight Swings (MAIN) I get the following error when running the trace capture script

(ChipWhisperer Target ERROR|File Ack error: ````

Warning                                   Traceback (most recent call last)
/tmp/ipykernel_5085/ in <module>
     11 key, text =
     12 #print(target)
---> 13 target.set_key(key)
     15 scope.adc.samples=5000

/usr/local/lib/python3.10/dist-packages/chipwhisperer/capture/targets/ in set_key(self, key, ack, timeout, always_send)
    548             if ack:
    549                 if self.simpleserial_wait_ack(timeout) is None:
--> 550                     raise Warning("Device failed to ack")
    551         else:
    552             target_logger.debug("Key unchanged, skipping send")

Warning: Device failed to ack

I was able to run through the entire module before and only when re-performing the module as the power trace looked inaccurate in that it was smaller than expected

When re-performing, I received the above “Failed to ack” error.

I have tried:
1.) Restarting jupyter + restarting browser
2.) Re-plugging chipwhisperer to different USB ports
3.) changing baud rates (note I only tried 115200, and 38400)
4.) Un-commenting the putch “hello” in source code - which did not put out a clean hello
5.) Patching to 5.1.3

Likely culprits are either (1) the firmware wasn’t uploaded to the target, or (2) there’s a mismatch between the SimpleSerial version that the target was compiled with, and the SimpleSerial version being used to talk to the target. You shouldn’t play with the baud rate, it will get set to the correct value for the SS_VER that you used in Lab 3_1 - Large Hamming Weight Swings (HARDWARE).ipynb.
I would undo any modifications you did there and start fresh.