Device failed to ack

Hello guys! I just got the CWNANO and I’m trying to get it to work but I’m having some problems.

I’m on the jupyter notebook 1- Connecting to Hardware and I’m having this error:

Can somebody help me? I tried looking for answers on the forum but to none avail.

Also, I uncommented the “hello” on serialbase.c and it printed just fine.

That’s a really strange error - line 304/305 of ( is just checking that the first character is ‘z’, which it looks to be here. I’ll see if I can replicate this.


I’m trying again and saw that the code on line 304/305 had a ‘a’ instead of ‘z’. But I edited it and it’s still not working.

Also, just wanted to say that even with this error I completed Lab 2_1B - Power Analysis for Password Bypass without any problems so I guess everything is okay with the board.

That’s strange, the code for that part has never been 'a'. Where did you install ChipWhisperer from? Are you on a fork of the code base?


I did the Windows Bundle Installer from here: ChipWhisperer — ChipWhisperer 5.6.1 documentation