Error during a tutorial

I’m trying to follow this tutorial:
but after opening the “ChipWhisperer-Rev2: SimpleSerial Target” example script (for capturing) I got this message:

What could I do?


Was the CW-Capture Rev2 device connected and appeared to be working? It seemed the USB failed, does it show up in the control panel ok?

  • Colin

I know it seems strange but everything is connected. Here is what the “Player > Removable Devices” looks like:

I also tried the “lsusb” command in a terminal and here is the result:

So it’s connected and I don’t understand :frowning:

Ah alright, so it’s connected OK. Can you try running the CW-Capture as “root” (using “sudo” for example) to test there is no issue w.r.t. being able to access the USB device? That can sometimes cause issues too…

Also you sometimes have to run the connect script twice I found. The first time it programs the FPGA/USB chip, but the computer doesn’t switch the USB connection fast enough. The second time through it should then connect to the programmed FPGA/USB-Chip.

I’ve tried both solutions: twice and with the root user and always the same error…

Hmm… sorry have been trying to recreate here! Is it possible to tell me the version of Python & PyUSB. To get these:

  1. Python version is printed at startup if you run a python console

  2. For PyUSB, type the following at a Python console:

import usb

and pyusb I use the virtual machine and I never installed anything more (I used “apt-get” so maybe it pgraded something) It’s Python 2.7.9 and PyUSB 1.0.0b2.

Sorry, I’ve to change the NumLock every time I use the virtual machine and that made my previous post unreadable.

As a stopgate, you could try installing the release on your host OS. There might be some issue with the VM?

Still trying to recreate here…

OK, I’try tomorrow and I’ll let you know…

Now I try to install it directly on my computer (Windows 7 Enterprise x64) and doing the installation procedure available on … installing , the 2.2.2 confirmation step (opening the analyzer) is giving this error:

[code]C:\Users\rm231795\chipwhisperer-0.12RC1\software\chipwhisperer\analyzer>python C
ERROR: PySide is required for this program

C:\Users\rm231795\chipwhisperer-0.12RC1\software\chipwhisperer\analyzer>pip inst
all PySide
Collecting PySide
Using cached PySide-1.2.4-cp27-none-win32.whl
Installing collected packages: PySide
Successfully installed PySide-1.2.4

C:\Users\rm231795\chipwhisperer-0.12RC1\software\chipwhisperer\analyzer>python C
libpng warning: iCCP: known incorrect sRGB profile
Traceback (most recent call last):
File “”, line 745, in
File “”, line 738, in main
window = ChipWhispererAnalyzer()
File “”, line 116, in init
self.traceExplorerDialog = TraceExplorerDialog(self)
File “c:\users\rm231795\chipwhisperer-0.12rc1\software\chipwhisperer\analyzer
utils\”, line 73, in init
File “c:\users\rm231795\chipwhisperer-0.12rc1\software\chipwhisperer\analyzer
utils\”, line 101, in setupCommonScripts
self.paramTreeCommonScripts.setParameters(self.paramCommonScripts, showTop=F
File “C:\Users\rm231795\WinPython-32bit-\python-2.7.10\lib\site-packag
es\pyqtgraph\parametertree\”, line 47, in setParameters
self.addParameters(param, showTop=showTop)
File “C:\Users\rm231795\WinPython-32bit-\python-2.7.10\lib\site-packag
es\pyqtgraph\parametertree\”, line 77, in addParameters
self.addParameters(ch, root=item, depth=depth+1)
File “C:\Users\rm231795\WinPython-32bit-\python-2.7.10\lib\site-packag
es\pyqtgraph\parametertree\”, line 77, in addParameters
self.addParameters(ch, root=item, depth=depth+1)
File “C:\Users\rm231795\WinPython-32bit-\python-2.7.10\lib\site-packag
es\pyqtgraph\parametertree\”, line 77, in addParameters
self.addParameters(ch, root=item, depth=depth+1)
File “C:\Users\rm231795\WinPython-32bit-\python-2.7.10\lib\site-packag
es\pyqtgraph\parametertree\”, line 64, in addParameters
item = param.makeTreeItem(depth=depth)
File “C:\Users\rm231795\WinPython-32bit-\python-2.7.10\lib\site-packag
es\pyqtgraph\parametertree\”, line 484, in makeTreeItem
return self.itemClass(self, depth)
File “c:\users\rm231795\chipwhisperer-0.12rc1\software\chipwhisperer\common\Pa”, line 27, in init
WidgetParameterItem.init(self, param, depth)
File “C:\Users\rm231795\WinPython-32bit-\python-2.7.10\lib\site-packag
es\pyqtgraph\parametertree\”, line 42, in init
w = self.makeWidget()
File “c:\users\rm231795\chipwhisperer-0.12rc1\software\chipwhisperer\common\Pa”, line 128, in makeWidget
l = self.makeLayout()
File “c:\users\rm231795\chipwhisperer-0.12rc1\software\chipwhisperer\common\Pa”, line 106, in makeLayout
File “C:\Users\rm231795\WinPython-32bit-\python-2.7.10\lib\site-packag
es\pyqtgraph\widgets\”, line 160, in setOpts
raise TypeError(“Invalid keyword argument ‘%s’.” % k)
TypeError: Invalid keyword argument ‘set’.[/code]
What should I do?


Ah the WinPython installer changed on me - you need to do an additional step now:

pip install pyside

Will update that in the docs! The release changed at some point in the past and stopped included PySide.


Also - there will be another error with the latest version, the fix is contained in this thread: viewtopic.php?f=7&t=76&p=400&hilit=winpython#p400

An upcoming release will also fix that, but that’s at least a few days away.

I don’t understand how to fix the problem.

The first issue (pip install) or second? For the second, the hack is to navigate to C:\WinPython-32bit-XXXX\python-2.7.10\Lib\site-packages\pyqtgraph\widgets , then open the “” file. Go to around line 157 (which should look like … and change the “self.opts” to “opts”.

I’m working on seeing if there is better fix that might be easier to send you.

Alternatively, download an older version of WinPython ( is reported to work, and is what I am using right now). This is the fastest/easiest way to move forward! You may still need to run the ‘pip install pyside’ command.

OK, that’s working. (pyside was installed as written in the log).
Now the “Project Text Editor” window is showing:

Failed to Open File, Exception: [Errno 2] No such file or directory: 'untitled.cwp'
Maybe it’s nothing to worry about as the project is opening correctly in the capture software.
So I have a working installation and I can go on…

PS: As I got visual problems the font size is very small for me. I found how to increase that with Linux but it seems impossible with Windows…


Alright great - yes you can ignore that warning I think, it’s just when there is no project by default it comes up!

I’ll take a look at font size increase, I actually wanted to do that as well for use on high-res screens. I’m not sure if the ChipWhisperer software respects the Windows font size settings (there is a default “increase font size by XX %” option available), but would be nice to have CW-Specific as well within the program.


And I think you want to take a look at the virtual machine too as a Windows installation is ok but the vm won’t work…