Failed to connect CW308_FE310 with red_blue LEDS

Hello,

I have a technical problem, I was trying to connect a CW308_FE310 ( FE310_mounted on UFO) and both are connected to CWLite

At first, using the setup script it connected and advised to upgrade, I tried to upgrade using “scope.upgrade_firmware()” but that didn’t work ( if I remember correctly I got an error hat starts with LIB)

When I plugged in the usb, it got identified as “Atmel Corp. at91sam SAMBA bootloader”

Also the green LED that should light up on the CWLite doesn’t anymore and instead I get a very weak blue and a very weak red LEDs.

Thanks in advance for your help.

Ok, apparently my CW is in bootloder mode, to fix this we have to flash firmware.

BOSSA on windows or bossa command line on ubuntu/linux are used to do so.

However in this site where it’s explaind how : Manual SAM3U Firmware Update - ChipWhisperer Wiki
when using the command we have to specify the .bin file to flash, in my case for the CWLite it’s SAM3U_CW1173.bin. This file should be in the following repo :
Chipwhisperer/hardware/capture/chipwhisperer-lite/sam3u_fw/SAM3U_VendorExample/Debug/

And my problem (for now) is that there are only make files in this repo

I am no expert in makefiles and how to use them, I only know that using the command make where there is a file named Makefile executes what’s in the makefile and I thought that doing that would help me get the SAM3U_CW1173.bin file, but this didn’t work due to the following error :

make: cmd.exe: Aucun fichier ou dossier de ce type
make: *** [Makefile:380 : src/ASF/common/services/usb/class/cdc/device/udi_cdc.o] Erreur 127

“Aucun fichier ou dossier de ce type” means : no file of this type
Erreur means error
The language of the PC I’m using is french

Like I said I’m not good with makefile, also is written in the makefile that it shouldn’t be edited so I don’t want to anything stupid.

Does anyone know what to do to get SAM3U_CW1173.bin ? Would flashing SAM3U_CW1173.bin even fix the problem of red/blue leds ?

Thanks in advance.

Ahmed

There is no need to re-compile the binary, you should find it here:
hardware/capture/chipwhisperer-lite/sam3u_fw/SAM3U_VendorExample/src/ChipWhisperer-Lite.bin

Ok, Thanks a lot.

My current problem is that the bossac command line can’t detect the right serial port, except that when using the -p option to tell the bossac which port should be used it can’t detect either.

I Have checked the existence of the serial port using tree command then I tried all the variations possible to tell it to what serial port the device is connected, here’s a photo :

I’m no expert with linux commands, I tried to look online but to no avail. Is this a problem with the command I’m trying to execute? If so what is the right command ? And if not, what is causing the CW not to be detected ?
No other card or anything is connected to a usb port. Would it be easier doing this on Windows ?

Thanks again for the help

Have you tried: Updating Firmware — ChipWhisperer 5.7.0 documentation

So I did do what’s advised in this site, the problem though is that now I have another error :

I have no idea what wrong, Is the CW not supported or is it something else ?
Would be really weird if the card is not supported because it’s a CWLite

Thanks again for your time and I really there’s a solution for this problem, I hope that I didn’t brick the CWLite.

It should be noted that I’m not using the bossac command for which the git is provided in the following site : Manual SAM3U Firmware Update - ChipWhisperer Wiki

I’m rather using the bossac command that is already compiled and ready to be put in PATH. the reason why I did so is because compiling the and executing the make for the makefile results in this error :

I also tried to do the same but from the git : GitHub - shumatech/BOSSA: BOSSA is a flash programming utility for Atmel's SAM family of flash-based ARM microcontrollers. The motivation behind BOSSA is to create a simple, easy-to-use, open source utility to replace Atmel's SAM-BA software. BOSSA is an acronym for Basic Open Source SAM-BA Application to reflect that goal. in which there’s a newer version of bossac I believe but I just got another error

EDIT: I also just read that it’s impossible to brick the CW.

Have you tried:

import chipwhisperer as cw
cw.program_sam_firmware(hardware_type='cwlite')

No, anyway I won’t need to because I just used the BOSSA application on windows and it solved the problem that I had been working on for hours in seconds.

Thanks a lot again for your time, if I ever get this problem again I’ll try the last solution that you provided to see if it works.