FPAG unprogrammed. Waiting on Bitstream when connecting CW1200


#1

Hi,

Now I firstly connect my ChipWhisperer CW1200 to my laptop via USB.
Instead Chipwhisperer should be recognized by my laptop, following error message comes up:

FPGA unprogrammed - Waiting on BitStream.

Is there any problem on the Chipwhisperer or do I have some missing to install?

Thanks,


#2

The usb driver installed well like below.

image


#3

The FPGA gets programmed by the ChipWhisperer software.
Assuming you’re using CW5, this happens when you run any of the tutorials, or run the following:

import chipwhisperer as cw
scope = cw.scope()

#4

I don’t understand what you said.

I followed all instruction for using CW5 and I am using Virtual machine (Virtual box for CW5) to run the exercises.
But, when I tried the first example for serial communication (click the “run” button in in Jupyter").
There is nothing happen. The message on Chipwhisperer is the same, “FPGA unprogrammed. Waiting on Bitstream”.

Also, I tried to the connection for CW4 through Virtual machine (VMware in this case).
Then, the error message is the same with that for CW5. The Chipwhisperer doesn’t get any signal from the Virtual machine and Jupyter.

How to solve this issue? Could you give me direct answer?

Thanks


#5

Sorry, it wasn’t clear that you had already done that.
What is the output in Jupyter when you run the following:

import chipwhisperer as cw
scope = cw.scope()

#6

Sorry for confusing. It’s working well now after solving some problem blocked in my company.
Maybe, I think it didn’t work when the usb driver didn’t set correctly for security reason in my company.
Thanks for your help JP