Fresh CW1173 install on a Windows 10 Pro laptop

I did a complete manual installation using the New Release method on my Win10 pro laptop of the following:
-Python, 32 bits
-CW1173 V 3.5.4
I can open but not running the CWCapture or the CWAnalyzer and I get this message: AttributeError: ‘function USB_find_busses’ not found.
Could not find updated installation documentation for version 3.5.4
Is there anyone out there with a fix or documentation about that issue?
Thanks and Best regards,

Hi jeanyves,

There are two reasons I can come up with now, that you receive an Attribute Error when you start the software:

  1. “pyusb” a python library is not installed or incorrectly installed. This can be fixed by running: “pip install pyusb”
  2. A problem with the libusb dll backend for pyusb on windows 10

One more way to possibly fix the problem:
Use the “requirements.txt” to double check you python package installation. Here is the Github Link.
You can use the file like this: “pip install -r requirements.txt”, that should install anything you are possible missing.

If this does not fix it, I can help you further if you give me the print out of the full error.

Best of luck,

Hi Franz,
You fast response is greatly appreciated. I followed your advises with no significant result.
The “pip install-r requirements.txt is not recognized by python besides, I reloaded the files you suggested and five were not installed.
Find below the console logs when I retried the CW1173:
c:\chipwhisperer\software>python CWCapture.pyw
INFO:Dictionary contains zero modules
INFO:Could not import module: chipwhisperer.capture.auxiliary.FrequencyMeasure: No module named matplotlib.mlab
WARNING:T-test inputs: no AES module found. Using pseudorandom plaintexts instead
INFO:Could not import module: chipwhisperer.analyzer.preprocessing.decimation_clock_recovery: No module named matplotlib.mlab
INFO:Could not import module: chipwhisperer.analyzer.preprocessing.resync_resample_zc: No module named matplotlib.mlab
INFO:Could not import module: chipwhisperer.capture.scripts.chipwhispererlite_scard: No module named _base
ERROR:Traceback (most recent call last):
File “c:\chipwhisperer\software\chipwhisperer\capture\ui\”, line 166, in doConDis
if self.api.connect():
File “c:\chipwhisperer\software\chipwhisperer\common\api\”, line 277, in connect
return self.connectScope() and self.connectTarget()
File “c:\chipwhisperer\software\chipwhisperer\common\api\”, line 239, in connectScope
File “c:\chipwhisperer\software\chipwhisperer\capture\scopes\”, line 60, in con
if self._con():
File “c:\chipwhisperer\software\chipwhisperer\capture\scopes\”, line 99, in _con
File “c:\chipwhisperer\software\chipwhisperer\capture\scopes\openadc_interface\”, line 82, in con
possible_sn =
File “c:\chipwhisperer\software\chipwhisperer\capture\scopes\cwhardware\”, line 56, in get_possible_devices
return self._cwusb.get_possible_devices(idProduct=idProduct)
File “c:\chipwhisperer\software\chipwhisperer\hardware\naeusb\”, line 97, in get_possible_devices
dev = list(usb.core.find(find_all=True, idVendor=0x2B3E, idProduct=id, backend=libusb0.get_backend()))
File “C:\WinPython-32bit-\python-2.7.13\lib\site-packages\usb\”, line 1246, in device_iter
for dev in backend.enumerate_devices():
File “C:\WinPython-32bit-\python-2.7.13\lib\site-packages\usb\backend\”, line 440, in enumerate_devices
File "C:\WinPython-32bit-\python-2.7.13\lib\ctypes_init
.py", line 375, in getattr
func = self.getitem(name)
File "C:\WinPython-32bit-\python-2.7.13\lib\ctypes_init
.py”, line 380, in getitem
func = self._FuncPtr((name_or_ordinal, self))
AttributeError: function ‘usb_find_busses’ not found

I rechecked the usb driver installation on my computer.
This kind of problem will surely be useful to learn Python. Your help is much needed and appreciated.

Best regards,

Hi jeanyves,

We did some further investigation. The problem is on our end, most likely when we recently updated drivers for the hardware. Thanks for bringing this up, we will fix it as quick as we can.
I created a github issue so you can track the progress.

Side Note: I updated the requirements.txt. This should get rid of the “no module named matplotlib” error at the beginning of the error message.

Another side note: If “pip install -r requirements.txt” gave you an error it is most likely due to:

  1. Not having pip (the package manager for python) installed. If you search “how to install pip” it should give you a sensible tutorial, there is a lot out there.
  2. You current working directory when running the command “pip install -r requirements.txt” was not .
  3. pip is not in your system’s PATH. You can search variations of how to add the pip and python directories to your environment variable PATH.

Hopefully one of these fixes works for you and we will work on the “function ‘usb_find_busses’ not found” bug on our side.

Let me know if you have any other questions. If they are not related just start a new topic and I can help you there.


If the command pip is not available (which sounds plausible on Windows), it’s not too hard to mimic on any system:
python -m pip install -r requirements.txt

There was an error in the latest driver build - was attempting to pass WHQL and instead broke everything. In mean-time you can downgrade drivers using following procedure:

  1. Run a command prompt as admin:
    SET devmgr_show_nonpresent_devices=1

  2. Select “Show Hidden Devices” from one of the top menus

  3. Find all ChipWhisperer devices under the “libusb-win32” section of device manager. Uninstall them.

  4. Run the command at command prompt “pnputil -e” . Look for all hits of NewAE Technology Inc (i.e., remember name of oem24.inf)

  5. Run command “pnputil -d oemXX.inf” for each hit (there may only be one).

  6. Download & unzip drivers from … 4.0.1alpha

  7. Plug CW-Lite in. On driver install, tell it to use local resource and point to that folder you unzipped.

The slightly crazy instructions are needed to force a “downgrade” of driver version number. Once a fixed version is build (working on now) it will all be better…

Thanks Colin,

I will apply those “crazy” instructions and let you know about the out comings.
Your prompt guidance is very appreciated.

Attached is a test version of the drivers - it worked for me on Win 7, but my Win 10 test machine is setup a little funky so I’m not as sure on that.

It should update OK (no need for crazy force uninstall). Let me know if that seems to work or not.
cwlite_usbdriver - (151 KB)

Hi Colin,

Things are getting better. I localized the problem being my usb 2.0 hub not fully compatible with my computer’s usb3.0 port Lenovo i7 720.
The cw_lite seems to be working properly with your usb driver V1.2.6.0 now, while using the simple serial example. I will pursue with the drivers you sent me this morning and I will let you know soon. I want to make sure that the cw V3.5.4 is working properly on a Windows 10 machine.

Thanks for your help and best regards,


Hi Colin, SUCCESS!!!
My CW1173 scope finally works properly with version 3.5.4 on my Windows 10 machine.
I loaded your cwlite usbdriver - received last Friday but my computer failed to recognize it.
So doing some research on the Lenovo site revealed that they had some issues with the USB-3 / USB-C ports power management. I loaded their latest bios release to my laptop and redid the CW usbdriver installation. It installed correctly but failed to recognize the chipwhisperer-lite. I searched for the SAM3U driver in your file but could not find it, so I used the AT32UC3 driver instead and the USB communication with the CW was finally established without error messages as previously found with the capture application.

I presume that the issue is solved and I will be able to start working on my project related to Passenger Rail Transit communication systems.

I wish to thank you Colin, Franz and jmichel (Jean-Michel I presume) for your precious collaborative effort,s which reminds me that I’m not left alone in this fascinating world.