Getting syntax error while moving in the directories

Good morning,
I’m currently trying to build my own crypto implementation on the chipwhisperer. So after finding the chipwhisperer, I write:
cd …/…/…/hardware/victims/firmware/simpleserial-OWN-PROJECT

to build my implementation.
It is the exact same syntax as in the other project (DPA on AES for example). However, I get the error:
File “”, line 4
cd …/…/…/hardware/victims/firmware/simpleserial-OWN-PROJECT
SyntaxError: invalid syntax

Is there a reason it is not working here but working in the other projects ?

Thanks in advance

You have extra dots in your cd command; it should be cd ../../../hardware/victims/firmware/simpleserial-OWN-PROJECT

Strange, I only have two dots in my project and while pasting it here, a third point appeared.
So I think this is forum related

The only way I’ve been able to get an “invalid syntax” error is if I omit one of the two “%” in the %%bash line.
If this is still not the issue, can you paste your code here in a triple-tick code block and double-check that it’s pasted correctly?

Sure let me paste it here:

cd …/…/…/hardware/victims/firmware/simpleserial-OWN-PROJECT

As you can see the platform is still understanding it as “…”. I tried copying this into an IDE and it goes with “…”

Sorry, I meant back-ticks, so it shows as an unformatted code block.
Are you copying this from Jupyter? Where does the IDE come into play?
The %%bash is a Jupyter “script magic” command and won’t work outside of Jupyter, i.e. it won’t work if you try to execute this in a Python program. (If that’s what you’re trying to do, you’ll have to use something like subprocess.)

Oh ok let me try here:

cd ../../../hardware/victims/firmware/simpleserial-OWN-PROJECT

I’m copying in my IDE just to see how the format goes, but I’m not running it

Something’s not adding up. If I create that directory, I can run that without any errors.
I don’t know what else to suggest. Is there anything particular about your setup, or how you’re running this, that you haven’t mentioned?

Not really, I’m using normal settings. I will try to create a new project and see if that works.
Thanks for the help !

I created a new project and now this works perfectly. The project may be corrupted in some way. Thanks for your time !