Getting the software running ... errors ...

Hi everybody,

just received my CWlite today. Yeah!

However, I can’t get the software running.

On Mac OS X 10.10 (note: pyside is installed!):

sudo python File "", line 35 print "ERROR: PySide is required for this program" ^ SyntaxError: Missing parentheses in call to 'print'

On Windows 7 I get:

TypeError: Invalid keyword argument 'set'

Help highly appreciated :wink:

Hmm… what version of Python are you using? The first error sounds like a Python 3 problem (the CW Software has only been used with 2.7), the other one I’m not sure about.

I’m in the process of building/uploading the Virtual Machine image for the software which will make things easier to get running quickly! With my travel to DEFCON that was interrupted…

Hi Colin,

problem seems to arise with newest WinPython 2.7.10 64-Bit as well. Downgrading to seems to help.


Hmm… is there specific errors? Often that means some package was updated that the API changed slightly… when I get some time will try to duplicate!

In the mean-time there is a Virtual Machine image posted at … e_Releases - I was going to release it shortly so there isn’t good docs for it yet, but if you’ve used VMWare before should be reasonably easy to get running!

Very nice, using version worked just fine. I was able to run the demo (attacking the software of the XMEGA). Now need to check how I can read the recorded traces in Matlab (where I have implemented all my attacks :wink:

Is there by any chance a mapper that already does that?

Great! I don’t have a specific converter, but the format is pretty straight-forward. As an example of saving to a MATLAB script, see this version of another script: …

But you can easily read in the numpy files and save them as MATLAB using those scipy libraries instead of doing it at capture time.

im not good with python so i may not be describing this correctly but
I have run up against the “TypeError: Invalid keyword argument ‘set’” issue using WinPython-32bit-
I have traced the issue to a change in the way pyqtgraph’s spinbox handles kwargs, previously it would accept any kwargs even if they had no meaning to spinbox, but the current version will only accept keywords that it has in its self.opts (and min and max) and error for anything else, the change is on line 157 here: …
A nasty way to make it work is to change that line to “elif k in opts:” to make it work the way it did previously but the fact it specifically errors on unknown keywords makes me think this is intentional so the correct way should be to call the spinbox setOpts with only the kwargs it expects, i have tried to fix this and currently have the following in my from line 97 on although its probably wrong and should be looked at by someone who knows what they are doing, i.e. not me

[code] defs = {
‘value’: 0, ‘min’: None, ‘max’: None, ‘int’: True,
‘step’: 1.0, ‘minStep’: 1.0, ‘dec’: False, ‘decimals’: 0,
‘siPrefix’: False, ‘suffix’: ‘’


    for k in defs:
        if k in defs and k in opts:
            defs[k] = opts[k][/code]

I removed fixedsize from defs and replaced it with decimals as fixedsize appears to not be a valid keyword but decimals is and is used, and only update values already in defs rather than adding new ones, this may well break stuff as i have no idea where decimals is being set to 3 or what fixedsize was used for It seems to be working but i have no idea what im doing so your mileage may vary.


As a heads up to this old thread - I finally pushed a fix to github. So this shouldn’t happen whenever the next release occurs…