Going further

someone provided me with their ChipWhisperer-rev 2 kit (in an orange box) and I’ve followed this tutorial: newae.com/sidechannel/cwdocs/tutorial.html
Everything is OK. Now I see there’s a probe and LNA in the box and I’d like to use it to break an AES software implementation running on a software cpu on an external (already present) FPGA board. I think I guessed how to plug it on the cw board but I can’t make a project, capture trace(s) and everything.
Is there any other tutorial I could practice to learn all that?
Thank you.


Currently the posted tutorials are all that is available - the idea is to explore them a little bit, and hopefully they give you some background into getting the system working. It does require a moderate amount of effort to connect your own system, as you need to get the interface working between the CW-Capture and your target board for example. You can look at some of the SASEBO/SAKURA tutorials to see how other targets connect.



I use a ChipWhisperer-rev2 complete kit so I have an H-probe and an LNA I’d like to use to spy and break an external FPGA AES implementation but I don’t know how to do that.

I’ve read the tutorials available on newae.com/sidechannel/cwdocs/index.html but that doesn’t help me, there’s always something missing.
#B1: how to describe another platform?
#B6: how to setup the project to capture traces?
#B10: no option for capturing with the H-probe
#A5: nothing to create a project

Help me please, I’m stuck.


You’ll have to dig into the design a little to connect to external hardware. Applying the SCA attacks isn’t super straight forward, so it’s hard to give a concise tutorial that covers everything you need. Our docs are continously expanding so will touch on some of those, but won’t cover 100% of what you need!

I’d been working on an H-Field probe tutorial as-is, but haven’t uploaded it yet. Will try to get that done shortly.

For connecting to external hardware, you’ll need to design appropriate target/connection module. Alternatively you can try implementing the “simpleserial” protocol on the FPGA (described at newae.com/sidechannel/cwdocs/tut … mpleserial), but would require a small state machine to deal with incoming data.

How shortly will the tutorial be available?

I’m trying this: newae.com/sidechannel/cwdocs/tut … mpleserial
but at step 4 of no window opens… It’s telling “Connect failed” but the cables seem ok.

Can you post a screen-shot of your device manager? Perhaps the MK-II drivers weren’t installed? Try unplugging/re-plugging the USB-A cable on the back of the Capture-Rev2 box to see what changes in your device manager, a device should disappear and reappear if things are working.

You were right, the drivers were not installed correctly. I’ve downloaded it from Atmel, installed it (no more warning in the device manager) and even restarted to be sure but still the same…

Hi Binome,

Sorry on the delay here - closed for the holidays and getting back to things now!

So it still doesn’t appear in the device manager is what you mean by “the same”? Or does it appear now but without appearing in AVR Studio?


And now the delay is because of MY holidays. :wink:

The device manager is ok now the drivers are installed but AVR Studio is still telling the connection failed.

I thought about the privileges of my account (a user one) and I tried with a local administrator account but the connection still failed.

Does it give any more specific error? i.e. is it finding the AVR-ISP MK2 device, but now erroring out when it tries to find the AVR? Does the window pop up asking you for connection details?

Nothing more: the window disappears when clicking on the “Connect” button then reappears after 3 seconds telling it failed.

Is there a chance you can post the screen-shot? Still trying to figure out where it’s going wrong…

Do you get the list of possible devices to connect to? It might be looking for the wrong thing, there should be somewhere you can select tool (i.e., JTAG, AVR-ISPMKII, etc). You need to ensure it’s set to “AVR-ISP MKII” or something like that, and using the “usb” port.

My_ boss decided to take the board back, I can’t do anything from now on so I won’t bother you anymore.
Thanks for your help.

Ah shoot - while sorry I wasn’t able to get it running in time, if you get a chance again let me know!