Having a bunch of problems getting CWNano to work

I unfortunately was having problems getting the scope.capture() functions to work. It would return a TypeError or a timeout error. I’m not sure what causes it to switch between those errors; last night it was strictly a timeout error, but today it has been a TypeError.

I tried to start from scratch to debug the error, so using the VirtualBox image, I ran the Update Firmware script. It then hung up on “Entering Bootloader”, and now I’m unable to connect to at all. Turing off VirtualBox, Windows 10 recognizes it as a BOSSA Program Port (COM10).

I tried running

cw_firmware_updater_5_5_0.exe 10 cwnnano

but get the error

Loading cwnano firmware...
Traceback (most recent call last):
  File "firmware_updater\firmware_updater.py", line 49, in <module>
  File "firmware_updater\bootloader_sam3u.py", line 49, in con
  File "site-packages\serial\serialwin32.py", line 33, in __init__
  File "site-packages\serial\serialutil.py", line 244, in __init__
  File "site-packages\serial\serialwin32.py", line 64, in open
serial.serialutil.SerialException: could not open port '10': FileNotFoundError(2, 'The system cannot find the file specified.', None, 2)
[14056] Failed to execute script firmware_updater

This is actually the second time it’s gotten stuck in the Bootloader phase. The first time I was able to run the above script and it worked and restoring the firmware.

I’m not sure what to do now

Try running cw_firmware_updater_5_5_0.exe COM10 cwnnano instead.