Help Please

Hello, I’m new at this and ran into a problem. I followed the basic guide ( … comms.html). Manage to get everything working till the point of “Communicating from CW-Capture Software”, after clicking on the master connect and then clicking on the 1 button, the debug log would show

 WARNING: response to short (len=0) 

Went a bit further and change the setup to trigger pin IO4, clock source Target IO-IN, then I move onto the ADC Clock and when I select the clock source to be EXTCLK x4 via DCM, I get another warning in the debug log.

WARNING:response to short (len=0): For address 0x06=6 Sent Data: e4010002 Read Data: e4010002

Hi David,

What hardware platform are you using? Will help me narrow down things further.



The ChipWhisperer Capture Rev2 with the multitarget victim board, and the atmega328p mcu

Hi David,

Sorry on the delay - long weekend has slowed things down here. Anyway, does the programming work ok? The error about the “response too short” is often when the AVR isn’t responding to serial commands… which can also be an issue with fuses programmed incorrectly, or jumpers on the device are set incorrectly.

Does the “ADC Frequency” match the expected 29.4 MHz (i.e. 7.37 MHz x 4)? If you can send screen-shots of your settings it might help too, as can see if anything jumpers out at me either.



Hey Colin,

Sorry for late reply, there was a death in the family and only returned back to work today. Using the avr programmer, I’m able to successfully flash to the mcu, I get no errors or warnings. Below are the screenshots.

Sorry to hear about the circumstances, my condolences to you! I’m at the CHES + SEC-T conference so will be a little slower in responding as well.

Did the AVR work with the AES example? I’m wondering if the fuses were programmed incorrectly… the jumpers all look OK there that I can see.

Hi Colin,

I have completely reinstalled the operating system making sure everything is clean. I have been through some testing process and yet I still get the same errors. I Purchased 2 atmega328p MCU’s and 2 atmega168 MCU’s for testing. Acquired the chipwhisperer versions from 0.09 to 0.12.

Firstly I can confirm that the smartcard section of the multi-victim board does indeed work. I can insert a smart card directly into the attack device and I can use a PC/SC reader connected to the attack device and it works.

I moved back to MCU section and started going from chipwhisperer versions 0.9 to 0.12 following the tutorials using both the atmega328p and atmega168A MCU.

For tutorials 5.1 and 5.2, I get the same error/warning as in the previous post.
Tutorial 5.4. when entering “@@@” I get no login response, tried entering it in over 20 times and no response.
Tutorial 5.6 when loading the example AES script this is the following output I get:

Is there other ways I could debug the board? Do you think there is some fault in the board?



The board is pretty basic, so it’s possible to fail but there isn’t a lot to break! If you’ve replaced the AVR, can you confirm the fuse settings? This would be done in AVR Studio… if you can post a screen shot might be helpful. The fuses should be set to “external oscillator” (specific start-up doesn’t matter), and you must make sure the “CLKDIV8” is unprogrammed.

Sorry for the hassle in debugging, there is a lot of different stuff to look at! Do you have a scope by chance to check if data is going in/out?

One other form of debugging is to attach a jumper across the RX/TX lines as shown in the attached image. Everything you type on the TX line should display on the terminal emulator. If that works you can be confident the CW-Capture is working, it’s some issue with clocking/fuses/program in the AVR most likely then. The output drivers in the CW-Capture can be overloaded is one of the only real failure modes…



Hey Colin,

Just came by to say thank you, after making the changes in the fuse sections, everything started working correctly.

Kind Regards.

Awesome! I’ll try to make it more clear what those need to be set too, sorry it took so long to sort out!