How to enable V4 preprocessing?


#1

The CWAnalyzer V4 version, check “Enabled”, preprocessing not normally enabled.


#2

Hi aleo,
Is this a question or are you posting information for other users?
If this is a question and you are talking about the preprocessing window then it may be your saved settings. You can get back to the default window layout by Help > Preferences > Window Layout > Reset Settings and Exit. This should get reset your QSettings object and clear things like window layout. If you just want the Preprocessing window to show up after closing it, you can enable it in the Window > Preprocessing Settings. If this is not what you meant, feel free to correct me.
Cheers,
Franz


#3

Hi Fheubach;
I’m sorry.
My problem is that in version 4, I don’t know how to use the preprocessing module.
For example, I want to use “Digital Filter”, Preprocessing > Digital Filter > sets the parameter > Enabled, and the trace has not changed.


#4

Hi aleo,
The digital filter module may not have carried over in the changing of the api and the new cw 4.0 scripting interface, this is a bug on our part. The easiest thing for now would be to revert back to the latest release you are comfortable with. If you made any changes to you chipwhisperer repository you can save them and then run “git checkout tags/3.5.4”, that should bring you back to the latest release of ChipWhisperer software, as cw4.0 is in currently in alpha. Thanks for letting us know about this issue, we will get to fixing it.
Cheers,
Franz