Husky Windows OSError: Unable to communicate with found ChipWhisperer

Hi everyone,
I just got my hands on a Husky with the CW313 board and th SAM4S target board. Unfortunately I have some problems to get it running. And it is very similar to previous posts (1 2 3)
Any help is very much appreciated :slight_smile:
What I did:

  • I downloaded the Windows chip whisperer installer (v5.7.0) and run it successfully.
  • The Status LED on the husky is slowly blinking which should indicate that there is no usb problem from the husky side.
  • I checked the drivers and they are correct according to this site. The device manager shows only one usb husky device.
  • I use the jupyter notebook that comes from the installer for my python scripts.
  • This is my code

import chipwhisperer as cw
%run "../jupyter/Setup_Scripts/Setup_Generic.ipynb"

scope = cw.scope()
  • This is the error when executing cw.scope()
OSError: Unable to communicate with found ChipWhisperer. Check that 
another process isn't connected to it and that you have permission to communicate with it.
  • I also followed the steps from other forum posts to uninstall and re-install the drivers just to make sure I tried this before writing this post, but it was also not successful.

  • Here seems to be a post about changing a “rules” file, but the link to the rules file in the post is not accessable anymore (and probably also for Linux as far as I see).

Cheers and thanks for reading so far :slight_smile:

The scope = cw.scope() command is redundant because Setup_Generic.ipynb already executes that. This may be the cause of your error (you can’t connect to an already connected scope, as the error message indicates).

If you re-start the notebook and omit scope = cw.scope(), does %run "../jupyter/Setup_Scripts/Setup_Generic.ipynb" run cleanly?

If that works, then I recommend you start going through our courses here.

1 Like

Thanks for the quick response!
If I omit scope = cw.scope() it runs cleanly and I get the expected notification.
You are absolutely right, the combination of both code lines causes the error.
I wanted to have the Setup_Generic script (as seen in the ChipWhisperer Setup Test notebook) as assurance that the ChipWhisperer gets recognized and did not have a closer look what exactly is going on in this script. :sweat_smile:
I tried the introduction courses before, but also added the call to Setup_Generic (again for personal assurance). After removing this line and choosing the correct platform the scripts work as expected.

What a not so smart mistake from my side…

Thanks a lot!

1 Like