Installing on Centos 7


#1

Hello,
I am trying to install the ChipWhisperer tool on a Centos 7 machine (the exact Centos version is 7.6.1810).
Following the installation procedure at https://wiki.newae.com/Installing_ChipWhisperer#Manual_Install_-_Linux - section “Manual Install - Linux”, I was able to get the Analyzer tool working (I am using the version 3.5.4), while I am experiencing several difficulties in getting the Capture tool working, to use it on a SAKURA-G target platform.
When I run the built-in script “connect_sakurag_aes.py” I get the following error:

“/home/crocetti/cw/cw_capture/chipwhisperer/common/utils/parameter.py”, line 729, in setParameter
(value, str(parameter), child.getOpts()[“values”].keys()))
ValueError: Invalid value ‘FTDI (SASEBO-W/SAKURA-G)’ for parameter ‘[‘ChipWhisperer/OpenADC’, ‘Connection’, ‘FTDI (SASEBO-W/SAKURA-G)’]’.
Valid values: [‘NewAE USB (CWLite/CW1200)’, ‘Serial Port (LX9)’]

I followed the installation procedure more and more times, repeating more times the steps, and each step does not display any error message. Once I made the Capture tool fully working on another Windows machine, but now I am stuck from days.
Can someone help me?


#2

I was able to solve this problem: there was an error in the installation procedure of the FDTI drivers, because my CentOS 7 O.S. is a 64-bit O.S. and the installation guide is for 32-bit O.S… I just needed to install the driver within the /usr/local/lib64 folder instead of /usr/local/lib folder, as indicated by the installation guide.

Now the Capture tool is able to detect and recognize the SAKURA-G board, but I am still getting an error, because the tool is not able to connect it: it seems as it tries to connect it, but without success and after a while it goes into timeout. Maybe it depends on the fact that I am not able to unload the usbserial module, as suggested by the D2xxx drivers installation guide (rmmod usbserial), because it is a kernel built-in module: as indicated by the D2xxx drivers installation guide, I tried to perform

rmmod ftdi_sio
rmmod usbserial

before trying to use the SAKURA-G board, but I got (and still get) the following error when running the rmmod usbserial command:

rmmod: ERROR: Module usbserial is builtin

Some suggestion?