LPC1114 Fuse Bypass problems

I ran into an issue with the LPC 1114 fuse bypass tutorial. I connect to it and everything, but early on, I receive this error, and I’m not really sure what’s wrong. Any help is appreciated:


Looks like that tutorial is still using old bits of the API. I’ll get that fixed up. In the meantime, you should be able to fix the problem by removing:

target.key_cmd = ""
target.go_cmd = ""
target.output_cmd = ""


Thank you, Alex,
That took me a step further. Now I’m getting into a sync timeout issue:

I have a really silly question now that I come think of it. It just occurred to me that I haven’t uploaded any program to the LPC1114 (too eager to test after soldering up the modifications, and thought in the back of my head that it’s probably programmed with something anyways). Do I need to upload something like the lpc1114_first4096.bin that is in the /faultapp1/external folder or something similar? I’m not even sure what the files in /external do, as there is no readme file.

Anything you need to do with the stuff in external is already in the notebook. The bootloader we’re dealing with is flashed into the LPC’s ROM, so it’s already on there from the factory.

That error likely means there’s a communication issue between the chipwhisperer. Can you confirm all the board modifications are made and all the required connection are ok between the ChipWhisperer and the LPC (both are listed at the beginning of the lab)?


Thank you! Now it works as a charm. Silly me had put one of the wires to the CW Lite board one column too far. I should have thought something like that might be the problem when encountering a sync timeout issue. Anyways, many thanks for your help!

Just a follow-up question: how many hours should I expect the system to run before it manages to glitch with the parameters given in the tutorial? I’ve done the regular CW glitch-attack tutorials and know it can be time consuming. Should I change any of the parameters, or should it work out-of-the-box, so to speak?

I’m asking cause I had it running for like 8 hours without a glitch.

I don’t think it should take that long. There should be a freq_multiplier variable in the notebook. Can you try changing that to 2? IIRC that makes the lab more reliable.