Manual glitch triggering doesn't seem to work


#1

Hey there,

I’m very new to the chipwhisperer so most of this problem may very well be me being unable to use it correctly.
I tried the first glitching tutorial (A2 introduction to glitch attacks), but the glitching itself via the “manual trigger” button seemed to be not doing anything. I connected an external oscilloscope that showed a nice clock signal but without any glitches when pressing the button (please mind that I’m very new to hardware attacks so wrong usage of the oscilloscope may also be an issue). I used the values from the tutorial.
When I changed the “glitch trigger” from “Manual” to “Continous” the oscilloscope showed continous glitches in the clock signal, so the hardware setup seems to be working.
When manipulating the glitch width and offset and toggling the glitch trigger from manual to continous and back to manual at the right moment the loop yielded the expected wrong results.
Is it me being seemingly unable to follow a tutorial or is there a real issue with the chipwhisperer software or fpga firmware ?
Thanks in advance,
cyberdemon


#2

I will answer to my own question, if somebody runs into a similar problem:

The manual trigger is working, it just needed different values than the ones from the tutorial.
I’m using the XMEGA target on the ufo cw308 target board and needed values around glitch width 7.8 and glitch offset -3.5. I found these out by testing the automated triggering with a python script (also in tutorial A2) to adjust the values for offset and width. The glitch explorer showed several working values that also worked with the manual trigger.


#3

I am facing a similar issue, both manual and external single shot/continous glitching doesn’t seem to work for me. Only continous Glitch trigger works for me. I have a brand new chipwhisperer lite board and cant seem to get the basic glitching work :frowning: