Multiple problems with Release 4.0.1 on Windows 64


#1

Guys

Currently my CWLite is basically useless, because CWCapture does not work.

Firstly the installer does not install all the necessary plugins.

and even if I manually install the missing ones using pip, I still get an error as if the “scope” object does not exist

I’ve also tried the manual installation by cloning the github repo, but that has a completely different set of issues

e.g. only 3 scripts are available, in the GUI, and if I try to run the other scripts from the filesystem, most of them don’t work.


What version in Github is stable and actually works ???

As currently things are a complete disaster, and $250 worth of hardware is about as useful as a brick.


#2

Hi Roger,

Did you get the answer you were looking for from the issues you raised on github? If not let me know, I should be able to help you.

Kind Regards,
Franz


#3

Franz

I’m still having problems with release 4.0.1.

The simple “serial connect” script does not seem to setup the board correctly and the red LED next to the FPGA remains on.

In fact I don’t see any traffic to the FPGA at all, so either its not needed for that script or there is a problem sending the microcode to the FPGA

To make my CWLite work, I’m now using a local clone of the github repo and then I checked out the v3.2.0 tag, so that I’m using version 3.2.0 of the scripts etc

I also reflashed the XMEGA using the AES sample firmware, using the tool in CWCapture

BTW. The tools to upload to the XMEGA are missing from release 4.0.1, perhaps they have been moved

I think its probably best if I resolve my issues with V4.0.1 via the github issue which Colin is replying to

For anyone else reading this, I’d recommend the use of version 3.2.0 at the moment