Hi, new to forum so go easy on me!

Purhased cw lte with stm323xxxx target, installed cw5.1.3 windows 32bit OK, then worked through some of the basic jupyter tutorials executing commands within the simulator and results as expected all good downloading firmware to target etc completes OK. However my problem now relates to the standalone capture apllications, i firstly installed the latest version, spent a while trying to work out why it wouldnt work…python3 etc, so then installed v2 as per video on tube, this worked to a degree, so then looked into the v5 directories and a lot of .py files are missing for the software to work…so then i skipped v5 went to load v4a and again this worked and able to do basic serial tests and the jupyter still works as a seperate instance with this v4a installed in same directory, the problem i am having with v4a is to actually get some code into the target chip via the built in “Serial stm32f programmer app”, when i launch this and check signature BEFORE flashing firmware, i receive message in bottom left ‘assuming approriate BOOT pins set HIGH on STM32F hardware’, so basically via the v4a it wont sync with this newae original target chip, there are some jumpers on this target board…jp6,jp7,jp12, does anyone know what these are for? Does anyone know the basic settings for uploading/downloading code in the this stm32f3 THROUGH the chipwhisperer capture v4.0.0 application? Thanks in advance

If you’re new to CW and have no legacy need for using older releases of CW software, then I really recommend you don’t spend time trying to get V2 or V4 working, they’re obsolete and some things just won’t work. The biggest advantage to using the latest V5 version, from a new user point of view, is that the tutorials are better, easier to follow, and there are more of them.

Sounds like you were successful in installing and running the VM version of CW5, and now you’d like to get the advanced standalone install working? (correct me if I’m wrong)

Did you follow all the instructions here, including the prerequisites?

Note that what you get from the advanced manual installation isn’t better in any way than a VM install, other than the obvious – the overhead and diskspace requirements of running a VM. But in terms of features and what you can do with it, it’s exactly the same. Even the user interface is the same: with the VM, you’re interacting with CW from a browser running on your host machine (not in the VM), just as you would with the advanced install.


OK jp i will look at v5 again, thanks

Hi I have managed a workaround for v4x standalone i had to do this, checked boot0 pin was going high(it was 3.3v), so then tried this :-
hz 7370000 - x4 - t4 - t1RX- t2 TX - bord 38400 and now we have playtime :slight_smile: