No pulses at the glitch-output

I am trying to make VCC glitches as described in the F2 tutorial. Exactly the same. CW-lite is connected and configured by default. The target (STM32F1) is programmed. The code works fine, but the result of brute force is zero.
I determined that there are no pulses at the output of the glitch port. I tried using glitch_lp and glitch_hp, but that failed. Using an oscilloscope, I found that there were no pulses at the FPGA outputs (P66, P67)
Can someone tell me what is causing this? Program settings or hardware problems?

Hi, can you provide the output from print(scope) when you expect the glitch to be active? Also, can you verify that the trigger is going high with your oscilloscope?

We did update the glitch logic recently, so there might still be some bugs related to that.


I changed the target’s firmware so that the trigger pulse is longer

void glitch_infinite(void)

cnt = 2;
cnt = 1;
cnt = 0;

The pulse length was 2.5 μs, became 3 μs. Now it all worked.

Target - STM32F103, internal clock 8MHz. May be it was line capacity or bad contact

Thanks for the help!