OSError: Could not detect STM32F, check connections, BOOT MODE entry setup


We purchased the ChipWhisperer Lite 2-Part version. Using Virtual Box I had everything working correctly and was able to successfully execute a few of the tutorials. However, for some reason, it has stopped working and I get the error “OSError: Could not detect STM32F, check connections, BOOT MODE entry setup”.

It fails on the line “cw.program_target(scope, prog, fw_path)” in multiple tutorials. The previous line "%run “Helper_Scripts/Setup_Generic.ipynb” runs successfully.

Here are all of the things I have tried:

  • Reconnected all of the cables multiple times.
  • Powered off the system and upon reboot only ran VB and Jupyter to make sure no other app had control of the device.
  • One of our techs buzzed out all of the cables and said they were all fine. Also, the chip on the target board was tested and was also fine.
  • Tried different USB ports on the laptop.
  • Verified that USB 3.0 is selected in VB.
  • Checked device manager and ChipWhisper-Lite appears before VB runs and there are no errors.
  • The USB driver was manually loaded during the initial setup. And as stated, the tests used to run without error.

Any idea what could be wrong?

Thanks and regards,

Hi Tom,

Can you confirm the target you are using? If you are getting the STM32F error, that suggests it’s looking for a STM32F3 device. The normal 2-part version has an XMEGA target.

In which case check the PLATFORM= line in the notebook - is it specifying the correct target? That platform specification changes the programmer between STM & XMEGA - using the wrong programmer will give a general error like that!



Hi Colin,

Thanks for the reply. We do have the 2-part version. Changing to XMEGA resolved the issue.

Best regards,

OK perfect! Probably it sounds like a SW update was applied (git pull etc), as I think the default in all the notebooks is CWLITEARM right now. Will try and flag that as something we could include in the documentation, since it’s a non-obvious result.



Thanks Colin. We figured the software changed somehow.

Best regards,