Problem getting started (Mac)

Hi! I am trying to get started with ChipWhisperer on my MacBook Air, and have run into a problem. (I have some experience with CW on Windows, and getting started there was no problem.)
I try to run the script “PA_Intro_1-Firmware_Build_Setup”. I have done the installations properly, and all the previous blocks run successfully. But this block give an error I can’t figure out.

This is the block:

cd …/…/…/hardware/victims/firmware/simpleserial-base-lab1

This is the start and the end of the output/error:

SS_VER set to SS_VER_1_1
/Library/Developer/CommandLineTools/usr/bin/make: invalid option – O
Usage: make [options] [target] …

CalledProcessError: Command ‘b’cd …/…/…/hardware/victims/firmware/simpleserial-base-lab1\nmake PLATFORM=$1 CRYPTO_TARGET=$2\n’’ returned non-zero exit status 2.


That -O option was added quite a while ago, so it could be that you’re running an old version of make.

Can you run make --version and report that back?


Hi, Alex!
This is what I get:

GNU Make 3.81
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A

This program built for i386-apple-darwin11.3.0

Hi again,
Yes, that was the problem. I updated make and now it works fine. Thank you!


Hi, I also have this issue and i wondered how did you update the make file?


It sounds like the solution was updating make (not the makefile).
I don’t use macos for development but it looks like updating make is a common thing that macos users do; there are lots of answers on how to do this on stackoverflow.

It worked now. Thank you!