Problem with serial connection for STM32 target


#1

Hello,

I am currently trying to get the tutorial B1 (simple serial) running for the CW308T UFO board with an STM32F4 target.

I first tried the XMEGA target from the ChipWhisperer lite which worked perfectly.
Then I also tried the XMEGA target board for the CW308 which also worked as expected.

However, for the STM32 target boards (I tried different ARM targets) I can’t get the serial connection to work:

  • Programming works for both ChipWhisperer lite as well as with the ST-LINK/V
  • I also checked that the target is running with the ST-LINK software
  • When I run the CWCapture software I always get the following when triggering an encryption (after running connect and setup scripts):

INFO:SimpleSerial: protocol V1.0 detected
WARNING:Response length from target shorter than expected (0<34): “”.
WARNING:Timeout in OpenADC capture(), trigger FORCED
WARNING:Timeout in OpenADC capture(), trigger FORCED

Attached a picture that shows the configuration of my UFO board:

Any ideas what might be the problem or things that I may have missed?

BR and thanks for any help in advance


#2

Try to flash the firmware directly from Chipwhisperer Capture software.

Connect firstly with the simpleserial script, then setup the board with the proper python file, then go to Tools-> Serial SMT32 programmer, find the correct “hex” you’d like to use (on Github you’ll find both the SW and the HW version) and flash it. Once the procedure is terminated, press the reset button on the UFO board (S9 - nRST) and try to start a capture.

It worked for me!


#3

I’m getting the same issue, I even tried different version of compilers…

@tr3 : whats is your os, compiler version… because I did what you just mentioned but didn’t work :frowning:


#4

@Ba4 What compiler versions have you used? It seems like some versions of the gcc compiler don’t produce working binaries for whatever reason. For Windows, 2018-q2 should work, and on Linux 5.4.1 20160919 should work.

Alex


#5

Dear Alex, Thanks for your reply

I compiled the hex on the same version compiler as you mention, still getting the same message “WARNING:Timeout …”

I’m working on ubuntu 18 running on virtual machine,
compiler info:
arm-none-eabi-gcc (GNU Tools for ARM Embedded Processors) 5.4.1 20160919 (release) [ARM/embedded-5-branch revision 240496]
Copyright © 2015 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


CW4 install - Windows
#6

@Ba4:
I have success with Ubuntu 18.10, arm-none-eabi-gcc (15:6.3.1+svn253039-1build1) 6.3.1 20170620.
In my case, I must not change -mfloat-abi from ‘hard’ to ‘soft’ as suggested here; keep it as ‘hard’.
(It compiles cleanly with both settings, but with ‘soft’ the target is unresponsive, exactly as you describe).
Let me know if this solves your problem,
Jean-Pierre