Problems compiling for the STM32F UFO targetboard


I’m trying to run the Fault_2-Introduction_to_Vcc_Glitch_Attacks tutorial on the STM32F UFO target board, but seems to be having problems programming the device. After executing the following code

sample_size = 5

%%bash -s "$PLATFORM"
cd ../hardware/victims/firmware/glitch-simple

I get the following error message:

I’m using CW v 5.1.3. The glitch-simple folder is where it should be.

Sorry, meant “compiling”, not “programming”.

There are some Linux tools that the GNU Tools Arm release doesn’t have. I’ve attached them here for you to place in your own directory here:

C:\Program Files (x86)\GNU Tools Arm Embedded\9 2019-q4-major\bin

Make sure this folder is in your system paths

It should look like below when you’re done.

gnu_arm (1.7 MB)

Hope this helps! We’ll be updating the readthedocs soon and will include this zip there. I ran into this issue myself!

If this doesn’t fix your system and you want to “just get going” I’d recommend installing a Linux sub-system.

This will allow you to use all the normal Linux tools that I personally found a lot easier to setup.

Excellent! Adding the additional files to GNU Tools Arm release worked wonders. Thanks for the help!

1 Like