problems doing the first tutorial

I just received my chipwhisperer-lite. Thank you very much.
I hooked it up and tried to do the first tutorial using the Git based software (Capture V3.1.11).
Everything works but the last step:
Quote: “Hit the Run 1 button. You may have to hit it a few times, as the very first serial data is often lost. You should see data populate in the Text Out field of the monitor window. Note that each byte of the Text In is incremented in the Text Out field.”
Well, I do see the Text In, Text Out and Enc Key populated. But unfortunately the Expected line just has a “?”.
Is this expected? In the tutorial the line is filled.
Additionally the following warning is printed whenever I run the code:
WARNING:No samples received. Either very long offset, or no ADC clock (try “Reset ADC DCM”). If you need such a long offset, manually update “nosampletimeout” limit in source code.

Any ideas?

Found it in the old documentation. I was missing the pycrypto library wrappers. No I am getting some output in the expected field. Of course it does not match the Text Out, since the actual algorithm just increment the values by one and does not encrypt using AES.

Hi Ralf,

Sorry on the slow response - had been delayed the past few weeks and just catching up!

I had a report about a change in the API not reflected in one of the tutorials, so am going to double-check that now. This might have caught you up.

The current version requires pycrypto to get the AES expected output, it’s not installed as part of the dependancy. The software itself has some quasi-AES libraries so I should be able to remove that dependency (and perform the AES algorithm entirely in software).