[SOLVED] Unable to install the Windows USB drivers for CWL


#1

Hi

I’ve been trying to download and install the Windows drivers for my CWLite, but the wiki links to chipwhisperer.com which doesnt seem to be working, and the drivers other people have posted on this forum failed to install.

I’m not sure if the installation failure is a result of a version incompatibility or because of a Windows driver signing problem.

I get the usual

“Windows found driver software for your device but encountered an error while attempting to install it”

“Windows cannot verify the digital signature for the drivers required for this device”

etc

Is this a driver version issue or a digital signature issue, and where can I get the drivers for a brand new CWL board

BTW.
I have libusb-win32 installed, for some other devices I use. and the device type is appearing as libusb-win32
Is this correct? or do I have to use something like Zadig to change the device type


#2

Just to respond to my own post.

It looks like the only way to install the drivers is to install the whole Windows package

github.com/newaetech/chipwhisperer/releases


#3

Hi Roger,

Did the USB drivers in the newae_windowsusb_drivers.zip file that is part of the release not work?

Kind Regards,
Franz


#4

Franz

Sorry

I’d not see the separate drivers zip.

github.com/newaetech/chipwhispe … rivers.zip

Someone had posted a zip onto the forum a while ago, and I tried that, but it didnt work.

So I just ended up installing the whole 600Mb windows 64 bit release exe and the drivers worked (after a bit of messing around)
I already have other drivers installed for the BlackMagic Probe, which also use libusb-win32 and I had a partial clash, but most people probably wouldn’t have that issue

I’ve just uninstalled (deleted) the drivers that had been installed by the V4.0.1 W64 release exe and then re-installed, and tested using Version 3.2.0 of CWCapture (and associated files - by checking out tag 3.2.0 from my local repo clone), and its all working OK with those drivers.

I will mark the thread as Solved

Thanks


#5

Hi Roger,

Thank you, I am happy that worked for you!

Cheers,
Franz