SPA against RSA on XMEGA (8-bit implementation)

Hi! I am trying to execute the script /jupyter/courses/sca202/PA_SPA_2-RSA_on_XMEGA_8bit.ipynb, but getting the following error:

Please note I am using the following setup:

SS_VER = ‘SS_VER_1_1’

scope.clock.adc_src = “clkgen_x1”
scope.adc.samples = 24000

My target board is XMEGA.

Can you please help me resolve this problem?

Thank you.

Did the target programming via cw.program_target(scope, prog, fw_path) run successfully?

Yes, the target programming ran correctly.

However, when I complied the target code, I got the following warning:

I get some but not all of these warnings, which suggests that you have a different compiler version.
I have avr-gcc 5.4.0; can you try my .hex file? (13.6 KB)

I tried your .hex file but still getting the same error as before:

Time out happened during acquisition.

It sounds like there is an issue communicating with the target then.

One possible cause is SimpleSerial version mismatch: are you setting SS_VER in the notebook? You should not need to. The firmware I sent was compiled for SS_VER_1_1, which is the default; if you set SS_VER=SS_VER_2_1 in the notebook, then communication will fail due to the version mismatch.

Are you able to run any of the other notebooks successfully on your XMEGA target? If so that would eliminate most of the other possibilities (20-pin connector issues, improper setup on the CW308 board if you’re using that).

Are you using the CWLITEXMEGA board, or CW308 with an XMEGA target?

Yes I was setting the SS_VER to ‘SS_VER_2_1’.

Now I do not set the version to SS_VER_2_1 and I am able to capture the trace for the hex file you have shared. However, I am still getting the old error when I try with my hex file.

Thank you very much for the help.

1 Like