The device has no langid

hello, im trying to get everything to work with the cwlite, and im getting the following error while calling cw.scope() from line 313 :

" ValueError: The device has no langid (permission issue, no string descriptors supported or device error)

During handling of the above exception, another exception occurred:

OSError: Unable to communicate with found ChipWhisperer. Check that another process isn’t connected to it and that you have permission to communicate with it."

I’ve installed the compilers through the windows installer and also added the path to the enviroment variables, and followed the solution in this link :

but there are no hits for NewAE Technology Inc.

in addition to these issue’s, my bash terminal still doesn’t recognize the make command


The advice in that post is very outdated at this point, so I don’t recommend following it. If you open Device Manager, do you see ChipWhisperer-Lite under “Universal Serial Bus devices”?

Are you using bash via Jupyter, or do you have console window open? If it’s the former, try changing %%bash to %%sh and if it’s the latter, try starting via ChipWhisperer5_64\cw\mintty.bat (if you’re not already).


Yes it appears there, yet I still get the issue
and about the second issue regarding make, I have fixed it.

If you go to C:\Windows\System32, do you see a libusb-1.0.dll? Also, if you go to ChipWhisperer5_64\cw\home\portable\WPy64-3771\python-3.7.7.amd64\Lib\site-packages\usb1, do you see a libusb-1.0.dll there?


no, this is what I have in system 32

and I dont have a usb1 folder inside

Can you try running the following in Jupyter:

pip uninstall libusb1
pip install libusb1


I ran it successfully, and copied the libusb-1.0.dll to system32 and I still get the same message

can I get a follow up for this topic please ?


Sorry about the lack of follow up. Unfortunately, that error message doesn’t really tell us much about what the actual issue is. Basically, it means that Windows can see and do all the USB setup it needs for the device, but it won’t let libusb access it. AFAIK, Windows doesn’t tell you why it won’t let you access the device, so this is really tricky to debug. The only time I’ve seen this on Windows has been when using 32-bit Python on 64-bit Windows, but we only do 64-bit Python for our installer now, so I don’t think this is the issue.

You might be able to fix this by using our VM image instead, since that should bypass Windows.